ZJNU 1902 Why Did the Cow Cross the Road II dp

Why Did the Cow Cross the Road II

Time Limit: 3000MS Memory Limit: 3000K
Total Submissions: 30 Accepted: 10
Description

Farmer John raises N breeds of cows (1≤N≤1000), conveniently numbered 1…N. Some pairs of breeds are friendlier than others, a property that turns out to be easily characterized in terms of breed ID: breeds a and b are friendly if |a−b|≤4, and unfriendly otherwise.

A long road runs through FJ’s farm. There is a sequence of N fields on one side of the road (one designated for each breed), and a sequence of N fields on the other side of the road (also one for each breed). To help his cows cross the road safely, FJ wants to draw crosswalks over the road. Each crosswalk should connect a field on one side of the road to a field on the other side where the two fields have friendly breed IDs (it is fine for the cows to wander into fields for other breeds, as long as they are friendly). Each field can be accessible via at most one crosswalk (so crosswalks don’t meet at their endpoints).

Given the ordering of N fields on both sides of the road through FJ’s farm, please help FJ determine the maximum number of crosswalks he can draw over his road, such that no two intersect.

Input

The first line of input contains N. The next N lines describe the order, by breed ID, of fields on one side of the road; each breed ID is an integer in the range 1…N. The last N lines describe the order, by breed ID, of the fields on the other side of the road. Each breed ID appears exactly once in each ordering.

Output

Please output the maximum number of disjoint “friendly crosswalks” Farmer John can draw across the road.

Sample Input

6
1
2
3
4
5
6
6
5
4
3
2
1
Sample Output

5

题目链接

题意:给你左边n个数,右边n个数,按顺序向下排,如果a[i]和b[j]的差值绝对值小于等于4,那么我们就可以把他们连接起来,但是不能存在相交的情况,问最多可以连几条线。

解题思路:dp即可,对于一个a[i]和b[j],如果他们的差值绝对值小于等于4,那么,dp[i][j]=max(max(dp[i][j-1],dp[i-1][j]),dp[i-1][j-1]+1),否则,dp[i][j]=max(dp[i][j-1],dp[i-1][j]),因此我们直接dp暴力过,则dp[n][n]即为答案。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[1005][1005],a[1005],b[1005];
int n,ans;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)   scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)   scanf("%d",&b[i]);
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if(abs(a[i]-b[j])<=4)   dp[i][j]=max(max(dp[i][j-1],dp[i-1][j]),dp[i-1][j-1]+1);
            else dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
        }
    }
    printf("%d\n",dp[n][n]);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值