Fibonacci Again

171 篇文章 0 订阅

Problem Link : http://acm.hdu.edu.cn/showproblem.php?pid=1021

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36522    Accepted Submission(s): 17632


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 

Author
Leojay


code 1:

余数里面的一条公式:(a+b)%3 = (a%3+b%3)%3

-------------------------------------------------------------------------------------------------------------

#include<stdio.h>
int f[1000001];
int main()
{
int n,i;
f[0]=7;
f[1]=11;
for(i=2;i<=1000000;i++)
f[i]=(f[i-1]%3+f[i-2]%3)%3;
while(scanf("%d",&n)!=EOF)
{
if(n<2)
printf("no\n");
else
{
if(f[n]==0)
printf("yes\n");
else
printf("no\n");
}
}
return 0;
}

---------------------------------------------------------------------------------------------------------------------

code 2:

因为n将近1000000, 经过测试,即使用long long 64位数据存储fib数,在n为80多就会爆掉,因此,不能用一般方法处理,需要寻找其中的规律

这种题一般情况下会有规律。把前几个能被3整除的数的下标列出来一看,规律就出现了:2 6 10 14…,这就是一个等差数列嘛,这就好办了,an = a1 + (n-1)*4,那么an-a1肯定能被4整除。代码如下:

#include <stdio.h>

#include <stdlib.h>

 

int main(void)

{

       int n;

       while (scanf("%d", &n) == 1)     

       {

              if ((n-2)%4 == 0)

                     printf("yes\n");

              else

                     printf("no\n");

       }

       return 0;

}

该解法如果说还可以优化的话,那只能把取余运算变为位运算了。

if ((n-2)&3)

                     printf("no\n");

              else

                     printf("yes\n");

 

如果把数列前几项的值列出来,会发现数组中每8项构成一个循环。这也很好办。

代码如下:

#include <stdio.h>

#include <stdlib.h>

 

int a[8];

int main(void)

{

       int n;

       a[2] = a[6] = 1;

       while (scanf("%d", &n) == 1)

              printf("%s\n", a[n%8] == 0 ? "no" : "yes" );

       return 0;

}

其实这个还可以优化,我们仔细观察可以看到这些满足条件的下标有一个特点:

N%8 == 2或者n%8==6

代码如下:

#include <stdio.h>

#include <stdlib.h>

 

int main(void)

{

       int n;

       while (scanf("%d", &n) == 1)

       {

              if (n%8 == 2 || n%8 == 6)

                     printf("yes\n");

              else

                     printf("no\n");

       }

       return 0;

}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值