hdu4723 How Long Do You Have to Draw 贪心

How Long Do You Have to Draw

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 322    Accepted Submission(s): 128


Problem Description
There are two horizontal lines on the  XoY plane. One is y 1 = a, the other is y 2 = b(a < b). On line y 1, there are N points from left to right, the x-coordinate of which are x = c 1, c 2, ... , c N (c 1 < c 2 < ... < c N) respectively. And there are also M points on line y 2 from left to right. The x-coordinate of the M points are x = d 1, d 2, ... d M (d 1 < d 2 < ... < d M) respectively.
Now you can draw segments between the points on y 1 and y 2 by some segments. Each segment should exactly connect one point on y 1 with one point on y 2.
The segments cannot cross with each other. By doing so, these segments, along with y1 and y2, can form some triangles, which have positive areas and have no segments inside them.
The problem is, to get as much triangles as possible, what is the minimum sum of the length of these segments you draw?
 

Input
The first line has a number T (T <= 20) , indicating the number of test cases.
For each test case, first line has two numbers a and b (0 <= a, b <= 10 4), which is the position of y 1 and y 2.
The second line has two numbers N and M (1 <= N, M <= 10 5), which is the number of points on y 1 and y 2.
The third line has N numbers c 1, c 2, .... , c N(0 <= c i < c i+1 <= 10 6), which is the x-coordinate of the N points on line y 1.
The fourth line has M numbers d 1, d 2, ... , d M(0 <= d i < d i+1 <= 10 6), which is the x-coordinate of the M points on line y 2.
 

Output
For test case X, output "Case #X: " first, then output one number, rounded to 0.01, as the minimum total length of the segments you draw.
 

Sample Input
  
  
1 0 1 2 3 1 3 0 2 4
 

Sample Output
  
  
Case #1: 5.66
 


既然先要满足三角形最多,那么肯定是要把所有的点能连的都连起来,然后重点是最短线段长度,如图



黑线是已经连接的线,x和y是当前位置,下一条线有两种连接方法,即绿线和蓝线,c[x]->d[y + 1]和 d[y]->c[x + 1],因为c[x]->d[y + 1]较短,所以选这条,y到y + 1的位置上去,然后把这条线段累加上,如果蓝线较短的话则将x放到x + 1的位置上去,然后把这条线段累加上,注意初始化和最后的边界,每一步都这样择优,最后输出的线段长度和一定最小




#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>

using namespace std;

double c[100005], d[100005];

int main()
{
	int T, n, m, x, y;
	double a, b, h, len;
	scanf("%d", &T);
	for (int t = 1; t <= T; t++) {
		scanf("%lf%lf", &a, &b);
		h = fabs(a - b) * fabs(a - b);
		scanf("%d%d", &n, &m);
		for (int i = 0; i < n; i++)
			scanf("%lf", &c[i]);
		for (int i = 0; i < m; i++)
			scanf("%lf", &d[i]);
		x = y = 0;
		len = 0;
		while (x < n && y < m) {
			len += sqrt(h + fabs(c[x] - d[y]) * fabs(c[x] - d[y]));
			if (x == n - 1)
				y++;
			else if (y == m - 1)
				x++;
			else {
				if (fabs(c[x] - d[y + 1]) < fabs(c[x + 1] - d[y]))
					y++;
				else
					x++;
			}
		}
		printf("Case #%d: %.2f\n", t, len);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值