HDU 1241 Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29700    Accepted Submission(s): 17169


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2
2
题目的意思是找油井@,并且相邻的油井是一个,求油井的总数,此处要用到八个方向,而不是简单的四个。
简单的深搜,从第一个油井开始向四周扩展,遇到油井继续深搜,每遍历到的油井都要标记,深搜完继续下一个判断。可以直接套用dfs模板,
#include<stdio.h>
#include<string.h>

int next[8][2]={0,1,1,0,0,-1,-1,0,-1,1,-1,-1,1,1,1,-1};  //方向数组 
int v[105][105];    //标记数组 
int m,n;

char map[105][105];

void dfs(int x,int y,int count)  //count用来标记搜索到的油井 
{
	int k,tx,ty;
	
	map[x][y]=count;    //标记 
	
	for(k=0;k<8;k++)    //方向遍历 
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		
		if(tx<0||ty<0||tx>=m||ty>=n)  //越界判断 
		continue;
		
		if(v[tx][ty]==0&&map[tx][ty]=='@')  //未走到且是油井 
		{
			v[tx][ty]=1;    //标记 
			dfs(tx,ty,count);   //深搜  
			
			//此处不需要状态还原,因为每个油井只需要遍历一次 
		}
	}
	return ;
}

int main()
{
	int i,j,k,flag;   //flag记录油井的数量 
	
	while((scanf("%d%d",&m,&n)!=EOF)&&(m&&n))
	{
		getchar();   //吸收回车 
		memset(v,0,sizeof(v));  //清空数组 
		
		for(i=0;i<m;i++)    //输入地图 
		{
			for(j=0;j<n;j++)
			scanf("%c",&map[i][j]);
			
			getchar();
		}
		
		flag=0;
		
		for(i=0;i<m;i++)   //遍历 
		{
			for(j=0;j<n;j++)
			{
				if(map[i][j]=='@')
				{
					flag++;
					v[i][j]=1;    //标记 
					dfs(i,j,flag);
				}
			}
		}
		
		printf("%d\n",flag);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值