Hdu1241Oil Deposits



Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20759    Accepted Submission(s): 11925


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 
最经典的DFS题,非常适合像我这种新手。
//
主要思路是
主循环里遍历寻找未走过的@,从此处开始dfs;
dfs里面通过循环完成深度搜索,将所有与之有关联的都标记下,完成这个deposit的深搜后sum+1;
然后继续遍历搜索;
一次AC.
//
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int m,n;
char map[100][100];
int zhi[100][100];
int dm[8]={-1,1,0,0,-1,-1,1,1};
int dn[8]={0,0,-1,1,-1,1,-1,1};
char ch;
int dfs(int a,int b)
{
    map[a][b]=1;
    int c,d;
    for(int i=0;i<8;i++)
    {
        c=a+dm[i];
        d=b+dn[i];
        if(c>=0&&c<m&&d>=0&&d<n)
            if(map[c][d]=='@')
                if(!zhi[c][d])
                {
                    dfs(c,d);
                }
    }
    return 0;
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF&&
          m&&n)
    {
        int sum=0;
        memset(zhi,0,sizeof(zhi));
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin >> map[i][j];
            }
        }
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(map[i][j]=='@'&&(!zhi[i][j]))
                    {
                        sum++;
                        dfs(i,j);
                    }
        printf("%d\n",sum);
    }
    return 0;
}
//
下面这个只是标记的位置改了下,本质上没有区别
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int m,n;
char map[100][100];
int zhi[100][100];
int dm[8]={-1,1,0,0,-1,-1,1,1};
int dn[8]={0,0,-1,1,-1,1,-1,1};
char ch;
int dfs(int a,int b)
{
    int c,d;
    for(int i=0;i<8;i++)
    {
        c=a+dm[i];
        d=b+dn[i];
        if(c>=0&&c<m&&d>=0&&d<n)
            if(map[c][d]=='@')
                if(!zhi[c][d])
                {
                    map[c][d]=1;
                    dfs(c,d);
                }
    }
    return 0;
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF&&
          m&&n)
    {
        int sum=0;
        memset(zhi,0,sizeof(zhi));
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin >> map[i][j];
            }
        }
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(map[i][j]=='@'&&(!zhi[i][j]))
                    {
                        map[i][j]=1;
                        sum++;
                        dfs(i,j);
                    }
        printf("%d\n",sum);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值