HPU 4883 TIANKENG’s restaurant

TIANKENG’s restaurant
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2581 Accepted Submission(s): 963

Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.

Sample Input
2
2
6 08:00 09:00
5 08:59 09:59
2
6 08:00 09:00
5 09:00 10:00

Sample Output
11
6
题意:第一行输入t,第二行输入n(代表总共几波人过来),以下输入第x波的人数,到达时间,走的时间,求需要多少椅子;
题解:因为一天的时间不算很大,所以可以记录每一分钟的椅子使用量,把最大的数提出来就是答案;

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define LL long long
#define M 11000

int ti[M];
int main()
{
    int t, h, min, pe, st, en, n;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        int ans = 0;
        memset(ti, 0, sizeof(ti));
        for(int i=0; i<n; i++)
        {
            scanf("%d", &pe);
            scanf("%d:%d", &h, &min);
            st = h * 60 + min;
            scanf("%d:%d", &h, &min);
            en = h * 60 + min;
            for(int j=st; j<en; j++)
            {
                ti[j] += pe;//在该时间的椅子使用量
                if(ans < ti[j]) ans = ti[j];
            }
        }
        printf("%d\n", ans);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值