HDU 1085 (母函数)

Holding Bin-Laden Captive!
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 1085
Appoint description:
Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds– 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
Sample Input
1 1 3
0 0 0
Sample Output
4

推荐一个博客点此
题意:有三种硬币 1, 2, 5 元, 给你每一种硬币的数量,问你这些硬币所有组合里面无法组合成的最少的价钱是多少;
题解:母函数的方法,这次是求是否能组合成一个数而不是求一个数是怎么组合成的,而且这次不是无限制数量了,对数量上有一个限制

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define M 10001
#define RCL(a, b) memset(a, b, sizeof(a))

int sum[4], p[4] = {0, 1, 2, 5};
bool num1[M], num2[M];

void getnum(int maxm)
{
    RCL(num1, 0);
    RCL(num2, 0);
    num1[0] = 1;
    for(int i=1; i<=3; i++)
    {
        for(int j=0; j<=maxm; j++)
        {
            for(int k=0; k<=sum[i]*p[i] && k+j<=maxm; k+=p[i])//k 作为跳转的值,每次跳转为该种硬币的值,要小于第 i 种硬币的总价值,j + k也必须小于总值
            {
                if(num1[j])
                {
                    num2[j+k] = 1;
                }
            }
        }
        for(int j=0; j<=maxm; j++)
        {
            num1[j] = num2[j];//重置,保证下一次的叠加
            num2[j] = 0;
        }
    }


}
int main()
{
    int n, maxm;
    while(scanf("%d%d%d", &sum[1], &sum[2], &sum[3]))
    {
        if(!sum[1] && !sum[2] && !sum[3])
        {
            break;
        }
        maxm = sum[1]*p[1] + sum[2]*p[2] + sum[3]*p[3];
        getnum(maxm);
        for(int i=1; i<=maxm+1; i++)
        {
            if(!num1[i])
            {
                printf("%d\n", i);
                break;
            }
        }
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值