hdu 5347 MZL's chemistry 2015多校联合训练赛#5 打表

MZL's chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 385    Accepted Submission(s): 314


Problem Description
MZL define  F(X)  as the first ionization energy of the chemical element  X

Now he get two chemical elements  U,V ,given as their atomic number,he wants to compare  F(U)  and  F(V)

It is guaranteed that atomic numbers belongs to the given set: {1,2,3,4,..18,35,36,53,54,85,86}

It is guaranteed the two atomic numbers is either in the same period or in the same group

It is guaranteed that  xy
 

Input
There are several test cases

For each test case,there are two numbers  u,v ,means the atomic numbers of the two element
 

Output
For each test case,if  F(u)>F(v) ,print "FIRST BIGGER",else print"SECOND BIGGER"
 

Sample Input
  
  
1 2 5 3
 

Sample Output
  
  
SECOND BIGGER FIRST BIGGER
 

Source
 
百度,直接打表输出


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;

double res[100]={
0,
1312.0,
2372.3,
520.2,
899.5,
800.6,
1086.5,
1402.3,
1313.9,
1681.0,
2080.7,
495.8,
737.7,
577.5,
786.5,
1011.8,
999.6,
1251.2,
1520.6

};


int main(){
    int n,m;
    res[35] = 1139.9;
    res[36] = 1350.8;
    res[53] = 1008.4;
    res[54] = 1170.4;
    res[85] = 890;
    res[86] = 1037;
    while(cin>>n>>m){
        if(res[n] > res[m]) puts("FIRST BIGGER");
        else puts("SECOND BIGGER");
    }
    return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值