PC 110101 3n+1 Problem

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22:

22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is  conjectured (but not yet proven) that this algorithm will terminate at  n = 1 for every integer  n. Still, the conjecture holds for all integers up to at least  1, 000, 000.

For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and jincluding both endpoints.

Input

The input will consist of a series of pairs of integers  i and  j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

Output

For each pair of input integers  i and  j, output  ij in the same order in which they appeared in the input and then the maximum cycle length for integers between and including  i and  j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174


//水题,不过应该注意a<b 和 a>b 的情况 我一开始欠考虑了 WA了一次。试着用了一下Programming Challenge 的确比UVAOJ强多了。。UVA慢的我都受不了了。
//一开始考虑到可能会超时,居然没有,但是试了一下 1 999999 的确应该是超时了 如果按照题目给的条件的话这题不应该用枚举暴解。



#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
	int a, b, i, countn, k ,maxn;
	while (scanf("%d %d", &a, &b)!=EOF)
	{
		maxn = 0;
		if (a < b)
		{
			for (k=a; k<=b; k++)
			{
				i = k;
				countn = 0;
				while (i!=1)
				{
					if (i % 2 == 0) i = i/2;
					else i = i * 3 + 1;
					++countn ;
				}
				countn++;
				if (countn > maxn) maxn = countn;
			}
			printf("%d %d %d\n",a, b, maxn);
		}
		else 
		{
			for (k=a; k>=b; k--)
			{
				i = k;
				countn = 0;
				while (i!=1)
				{
					if (i % 2 == 0) i = i/2;
					else i = i * 3 + 1;
					++countn ;
				}
				countn++;
				if (countn > maxn) maxn = countn;
			}
			printf("%d %d %d\n",a, b, maxn);
		}

		
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值