ACboy needs your help again!

Problem Description

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3


<<<源代码>>>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
using namespace std;


void sta(int n){
	char str[10];
	int a;
	stack<int>s;
	while(n--){
		scanf("%s",str);
		if(!(strcmp(str,"IN"))){   //????????????? 
			scanf("%d",&a);
			s.push(a);
		}
		else if(!(strcmp(str,"OUT"))){  //????????????
			if(!(s.empty())){
				printf("%d\n",s.top());
				s.pop();
			}
			else
			 printf("None\n");
		}
	}
}


void que(int n){
	char str[10];
	int b;
	queue<int>q;
	while(n--){
		scanf("%s",str);
		if(!(strcmp(str,"IN"))){   //??????????
			scanf("%d",&b);
			q.push(b);
		}
		else if(!(strcmp(str,"OUT"))){   //??????????
			if(!(q.empty())){
				printf("%d\n",q.front());
				q.pop();
			}
			else
			 printf("None\n");
		}
	}
}




int main(){
	int m,n;
	char str[10];
	while(~scanf("%d",&m)){  //???还是不懂 
		while(m--){
			scanf("%d%s",&n,str);
			if(!(strcmp(str,"FILO")))   //????????????
			 sta(n);
			else if(!(strcmp(str,"FIFO")))   //??????????
			    que(n);
			else
			    printf("error\n");
		}
	}
}

 
  
 1.纯粹STL中栈和队列基本操作的应用  
  
   栈:stack<elem>s s.empty() s.push(elem) s.pop() s.top() 
   队列:queue<elem>q q.empty() q.push(elem) q.pop() q.front()
2.结合字符串中,字符串数组str[]的输入和字符串比较函数strcmp
3.n--
4.while(~scanf("%d",&m))
5.4 FILO 
   IN 1  IN 2 
   OUT        2 
   OUT        1  
   5 FIFO 
   IN 1
   IN 2 
   OUT        1 
   OUT        2
   OUT      None
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值