杭电1702 ACboy needs your help again!

考点:本题考查栈和队列的结合使用

题意:有多个测试数据。如果输入的数据采用先进先出(即题中的FIFO)则用队列方式进行存储并输出,这种方式存入队列时只要修改尾指针rear(尾指针+1),输出时修改头指针front(头指针+1),判断队列为空用(rear-front=0)。

如果采用先进后出(即题中的FILO),则用栈方式进行存储并输出,这种方式进栈时修改栈顶指针toptop+1),出栈时一定注意先取栈顶元素,然后再top--,进栈则是先top++,再向栈中放入元素。

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2900 Accepted Submission(s): 1507


Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input
   
   
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT

Sample Output
   
   
1 2 2 1 1 2 None 2 3

代码
#include<stdio.h>
#include<string.h>
int main()
{
	int i,n,top,m,t,front,rear,q,s[100];//用数组表示栈和队列
	char f[100],p[100];//用于存储进出栈和队列的方式(IN或OUT)
	scanf("%d",&n);
	{
		while(n--)
		{
			scanf("%d%s",&m,&f);
			top=rear=front=0;//初始时全部为0 
			while(m--)
			{
				scanf("%s",&p);
				if(strcmp(f,"FIFO")==0)//队列
				{		
					if(strcmp(p,"IN")==0)//入队
					{
						scanf("%d",&t);
						s[rear++]=t;
					}
					else if(strcmp(p,"OUT")==0)//出队
					{
						if((rear-front)==0)//判队空
							printf("None\n");
						else //队不空
							q=s[front++];
							printf("%d\n",q);
					}
				}
				else //栈
				{
					if(strcmp(p,"IN")==0)
					{
						scanf("%d",&t);
						s[top++]=t;
					}
					else 
					{
						if(top<=0)
							printf("None\n");
						else
							printf("%d\n",s[--top]);//这里一定要注意先输出栈顶元素,再												移动top指针
					}
				}
			}	
		}
	}
	return 0;
}

总结

这道题很好地介绍了栈和队列两种数据结构的应用,关键就是指针的修改,以及一些特殊情况,如栈空、队空。它不像我们以前严蔚敏数据结构学习中的类c语言代码一样很长,所以理解起来比较简单。另外,就是对于所有情况要考虑全面。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值