POJ 1273 Drainage Ditches

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 81243 Accepted: 31572
Description

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output

50
Source

USACO 93

题目大意:网络流模板,1是源点,n是汇点(多组数据);
做法:网络流模板

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#define max(a, b)   ((a) > (b) ? (a) : (b))
#define N 1007
#define INF 0x7fffffff
#define rep(i, a, b)    for (int i = a; i <= b; i++)
#define eg(i, x)    for (int i = ls[x]; i; i = e[i].next)
using namespace std;
struct edge
{
    int flow, to, next;
}e[N * 2];
int n, m, ls[N], d[N], cnt = 1;

void add(int x, int y, int z)
{
    e[++cnt].to = y;
    e[cnt].flow = z;
    e[cnt].next = ls[x];
    ls[x] = cnt;

    e[++cnt].to = x;
    e[cnt].flow = 0;
    e[cnt].next = ls[y];
    ls[y] = cnt;
}

int bfs()
{
    memset(d, -1, sizeof(d));
    d[1] = 0;
    queue<int> q;
    q.push(1);
    while (!q.empty())
    {
        int x = q.front(); q.pop();
        eg(i, x)
            if (d[e[i].to] < 0 && e[i].flow > 0)
            {
                d[e[i].to] = d[x] + 1;
                q.push(e[i].to);
            }
    }
    if (d[n] > 0)   return 1;
    return 0;
}

int dfs(int x, int mx)
{
    int a;
    if (x == n) return mx;
    eg(i, x)
    {
        if (e[i].flow > 0 && d[e[i].to] == d[x] + 1 && (a = dfs(e[i].to, min(mx, e[i].flow))))
        {
            e[i].flow -= a;
            e[i ^ 1].flow += a;
            return a;
        }
    }
    return 0;
}

int main()
{
    while (~scanf("%d%d", &m, &n))
    {
        memset(ls, 0, sizeof(ls));
        int x, y, z;
        rep(i, 1, m)
            scanf("%d%d%d", &x, &y, &z), add(x, y, z);
        int res;
        int ans = 0;
        while (bfs())
        {
            while (res = dfs(1, INF)) ans += res;
        }
        printf("%d\n", ans);
    }
}
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 、5资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值