hdu 3183(RMQ应用)

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 451    Accepted Submission(s): 147


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 

Source
 

Recommend
lcy
 
分析:这题可以通过变形为取n个数,使大小最小变成RMQ问题,没什么好说的。。。
这题一开始wa了无数次,原以为是ST算法写错,经过各种Debug,发现没有在ST()这个函数里重新开变量i,j,导致wa。。。所以函数里的变量还是尽量不要用全局变量了,特别是ST算法这种易错的东西。。。
代码:
#include<cstdio>
#include<cstring>
#define check(i,j) (a[i]<=a[j]?i:j)
using namespace std;
const int mm=1111;
int f[mm][11];
char a[mm],out[mm];
int i,j,k,n,m;
void ST()
{
    int i,j;
    for(i=0;i<n;++i)f[i][0]=i;
    for(j=1;(k=(1<<j)-1)<n;++j)
        for(i=0;i+k<n;++i)
            f[i][j]=check(f[i][j-1],f[i+(1<<(j-1))][j-1]);
}
int get(int l,int r)
{
    int k=0;
    while(l+(1<<k)<r-(1<<k)+1)++k;
    return check(f[l][k],f[r-(1<<k)+1][k]);
}
int main()
{
    while(scanf("%s %d",a,&m)!=-1)
    {
        n=strlen(a);
        m=n-m;
        ST();
        i=j=0;
        while(m--)i=get(i,n-m-1),out[j++]=a[i++];
        for(i=0;i<j;++i)
            if(out[i]!=48)break;
        if(i==j)putchar('0');
        while(i<j)putchar(out[i++]);
        puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值