hdu 3308 LCIS(线段树 最长连续递增)

LCIS

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1478    Accepted Submission(s): 665


Problem Description
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
 

Input
T in the first line, indicating the case number.
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
 

Output
For each Q, output the answer.
 

Sample Input
  
  
1 10 10 7 7 3 3 5 9 9 8 1 8 Q 6 6 U 3 4 Q 0 1 Q 0 5 Q 4 7 Q 3 5 Q 0 2 Q 4 6 U 6 10 Q 0 9
 

Sample Output
  
  
1 1 4 2 3 1 2 5
 

Author
shǎ崽
 

Source
 

Recommend
wxl


题目:http://acm.hdu.edu.cn/showproblem.php?pid=3308

题意:一个数列,每次可能更新一个数,或者问一个区间的最长连续递增。。。

分析:这题相比之前的还是比较简单的吧,只要保持每个区间从左边开始的最长连续,和从右边开始的最长连续,还有这个区间的最长连续,当然,这题的更新时单点更新的,比较简单。。。不过合并时注意判断是否满足合并条件啊,因此wa了一次。。。

代码:

#include<cstdio>
#include<iostream>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
const int mm=111111;
int num[mm],mlen[mm<<2],llen[mm<<2],rlen[mm<<2];
void pushup(int rt,int m,int l1,int l2)
{
    mlen[rt]=max(mlen[rt<<1],mlen[rt<<1|1]);
    llen[rt]=llen[rt<<1],rlen[rt]=rlen[rt<<1|1];
    if(num[m]<num[m+1])
    {
        mlen[rt]=max(mlen[rt],rlen[rt<<1]+llen[rt<<1|1]);
        if(llen[rt]>=l1)llen[rt]+=llen[rt<<1|1];
        if(rlen[rt]>=l2)rlen[rt]+=rlen[rt<<1];
    }
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%d",&num[l]);
        mlen[rt]=llen[rt]=rlen[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt,m,m-l+1,r-m);
}
void updata(int p,int val,int l,int r,int rt)
{
    if(l==r)
    {
        num[l]=val;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)updata(p,val,lson);
    else updata(p,val,rson);
    pushup(rt,m,m-l+1,r-m);
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)return mlen[rt];
    int m=(l+r)>>1;
    if(R<=m)return query(L,R,lson);
    if(L>m)return query(L,R,rson);
    int ret=max(query(L,R,lson),query(L,R,rson));
    if(num[m]<num[m+1])ret=max(ret,min(R,m+llen[rt<<1|1])-max(L,m-rlen[rt<<1]+1)+1);
    return ret;
}
int main()
{
    int i,j,n,m,t;
    char op[55];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        build(0,n-1,1);
        while(m--)
        {
            scanf("%s%d%d",op,&i,&j);
            if(op[0]=='U')updata(i,j,0,n-1,1);
            else printf("%d\n",query(i,j,0,n-1,1));
        }
    }
    return 0;
}


评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值