1134. Vertex Cover (25)

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.

After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2] ... v[Nv]

where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line "Yes" if the set is a vertex cover, or "No" if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No
题目的大意是:给你一张图,对于图中的每条边,如果该边(一条边有两个点)至少有一个点在集合里,如果这个图中的每个边都是满足的,那么我们把这个集合叫做vertex cover,现在给你几个集合,让你判断他们每个是不是这样的集合
思路:
1.将边作为基本元素进行保存
2.对每个边的两个顶点,判断这两个顶点是不是在集合里
3.为提高查找效率,选择使用set
4.为进一步提高效率,采用visit数组保存对于之前已经确定在集合里的顶点,以免重复查找
#include <iostream>
#include <vector>
#include <set>
#include <algorithm>
#include <functional>
using namespace std;
struct edge
{
	int u,w;
	edge(int x,int y):u(x),w(y){}
};
vector<edge> v;
int main()
{
	int n,m;
	cin>>n>>m;
	for(int i=0;i<m;++i)
	{
		int u,w;
		cin>>u>>w;
		v.push_back(edge(u,w));
	}
	int k;
	cin>>k;
	while(k--)
	{
		int num,visit[10000]={0},ret=1,idx;
		set<int> s;
		cin>>num;
		for(int i=0;i<num;++i)
		{
			cin>>idx;
			s.insert(idx);
		}
		for(auto x:v)
		{
			if(visit[x.u]||visit[x.w]) continue;//以及在集合里,直接跳过
			if(s.find(x.u)!=s.end()) visit[x.u]=1;
			else if(s.find(x.w)!=s.end()) visit[x.w]=1;
			else {ret=0;break;}
		}
		ret==1?cout<<"Yes\n":cout<<"No\n";
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值