100道动态规划——38 HDU 5763 Another Meaning KMP + DP

Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”. 
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.
 

Sample Input
  
  
4 hehehe hehe woquxizaolehehe woquxizaole hehehehe hehe owoadiuhzgneninougur iehiehieh
 

Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 5 Case #4: 1
Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”. In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.

        好吧,DP是显然的,KMP也是可选的,hash也可以,毕竟是字符串匹配。声明:有关于字符串数组的下标都从1开始

        定义状态dp[i]表示匹配串区间[1,i]的含义数,显然的,在不产生二义的情况下,我们有dp[i]=dp[i-1](dp[0]=1)

        但是产生二义的话,目前在i处恰好匹配了模式串,也就是意味着从[i-length_pattern +1,i]这一段区间都可以被表达成另外一个含义,由于开始dp[i]=dp[i-1]已经算过一种含义了,假若当前匹配成功的话,把这一段区间都换成另外一个含义,也就是dp[i]还要加上dp[i-length_pattern]

        PS:一开始考虑的状态转移方程没考虑到这个,导致做不出来。。。还是练少啦

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long ll;
const ll mod=1000000007;
const int maxm=100010;

long long times,dp[maxm]{1},nt[maxm]{-1},lenr,lens,kcase;
char raw[maxm],str[maxm];

int main(){
    ios_base::sync_with_stdio(0);
    cin>>times;
    while(times--){
        cin>>(str+1)>>(raw+1);
        lenr=strlen(raw+1),lens=strlen(str+1);
        for(int i=1,p=nt[i-1];i<=lenr;p=nt[++i-1]){
            while(p>=0&&raw[p+1]!=raw[i])p=nt[p];
            nt[i]=p+1;
        }

        for(int i=1,p=0;i<=lens;++i){
            dp[i]=dp[i-1];
            while(p>=0&&raw[p+1]!=str[i])p=nt[p];
            if(++p==lenr)
                dp[i]=(dp[i]+dp[i-lenr])%mod;
        }
        cout<<"Case #"<<++kcase<<": "<<dp[lens]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值