九度oj--1001和1048

题目1001:A+B for Matrices

题目描述:
This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.
输入:
The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.
The input is terminated by a zero M and that case must NOT be processed.
输出:
For each test case you should output in one line the total number of zero rows and columns of A+B.
样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5

import java.util.*;
public class Main {
    public static void main(String args[]) {
        Scanner cin = new Scanner(System.in);
        int arr1[][], arr2[][], rows=0, columns=0, count;
        boolean isZero;
        while(cin.hasNext()){
            count = 0;
            //读入行数和列数
            rows = cin.nextInt();
            if(rows == 0)
                return;
            else{
                columns = cin.nextInt();
                //读入数组
                arr1 = new int[rows][columns];
                arr2 = new int[rows][columns];
                for(int i = 0; i < rows; i++){
                    for(int j = 0; j < columns; j++){
                        arr1[i][j] = cin.nextInt();
                    }
                }
                for(int i = 0; i < rows; i++){
                    for(int j = 0; j < columns; j++){
                        arr2[i][j] = cin.nextInt();
                    }
                }
                //求和
                for(int i = 0; i < rows; i++){
                    for(int j = 0; j < columns; j++){
                        arr1[i][j] = arr1[i][j] + arr2[i][j];
                    }
                }
                //计算值都为0的行和列的数目
                for(int i = 0; i < rows; i++){
                    isZero = true;
                    for(int j = 0; j < columns; j++){
                        if(arr1[i][j] != 0){
                            isZero = false;
                            break;
                        }
                    }
                    if(isZero == true)
                        count++;
                }
                for(int j = 0; j < columns; j++){
                    isZero = true;
                    for(int i = 0; i < rows; i++){
                        if(arr1[i][j] != 0){
                            isZero = false;
                            break;
                        }
                    }
                    if(isZero == true)
                        count++;
                }

            }

            System.out.println(count);

        }
    }
}

一遍过,但是在写的时候又犯了两个老毛病:一个是“=”和“==”的区别;一个是在输出count后进入下一个例子时,需要把count的值恢复为0;

题目1048:判断三角形类型

题目描述:
给定三角形的三条边,a,b,c。判断该三角形类型。
输入:
测试数据有多组,每组输入三角形的三条边。
输出:
对于每组输入,输出直角三角形、锐角三角形、或是钝角三角形。
样例输入:
3 4 5
样例输出:
直角三角形

import java.util.*;
public class Main {
    public static void main(String args[]) {
        Scanner cin = new Scanner(System.in);
        int[] arr;
        int a,b;
        while(cin.hasNext()){
            arr = new int[3];
            for(int i = 0; i < 3; i++)
                arr[i] = cin.nextInt();
            Arrays.sort(arr);
            a = arr[0]*arr[0] + arr[1]*arr[1];
            b = arr[2]*arr[2];
            if( a == b )
                System.out.println("直角三角形");
            else if(a < b)
                System.out.println("钝角三角形");
            else
                System.out.println("锐角三角形");
        }
    }
}
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值