九度OJ 1001:A+B for Matrices

题目1001:A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:19343

解决:7745

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:
2011年浙江大学计算机及软件工程研究生机试真题


就是矩阵的加法,最后再循环一下求出行和为0 与列和为0 的个数,水题 直接给代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int M[1000][1000];
int N[1000][1000];
int R[1000][1000];
int main()
{
    int a,b,temp1,temp2,result;
    while(scanf("%d",&a)!=EOF){
        if(a==0) break;
        else{
            scanf("%d",&b);
            memset(M,0,sizeof(M));
            memset(N,0,sizeof(N));
            memset(R,0,sizeof(R));
            result=0;
            for(int i=0;i<a;i++){
                for(int j=0;j<b;j++){
                    scanf("%d",&temp1);
                    M[i][j]=temp1;
                }
            }
               for(int i=0;i<a;i++){
                for(int j=0;j<b;j++){
                    scanf("%d",&temp2);
                    N[i][j]=temp2;
                    R[i][j]=temp2+M[i][j];
                }
            }
            for(int i=0;i<a;i++){
                int sum=0;
                for(int j=0;j<b;j++){
                        sum+=R[i][j];
                        if((j==b-1)&&sum==0) result++;
                }
            }
            for(int j=0;j<b;j++){
                int sum=0;
                for(int i=0;i<a;i++){
                        sum+=R[i][j];
                        if((i==a-1)&&sum==0) result++;
                }
            }
            printf("%d\n",result);
        }
    }
}
/**************************************************************
    Problem: 1001
    User: th是个小屁孩
    Language: C++
    Result: Accepted
    Time:110 ms
    Memory:13236 kb
****************************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值