关闭

'<>' operator is not allowed for source level below 1.7

697人阅读 评论(0) 收藏 举报
分类:

In your project's preferences, you must set the compiler --source option to 1.7 and --targetoption to 1.7 also. There are dedicated option boxes for that.

Right-click on the project. Choose Properties. Choose Java Compiler on the left. Choose 1.7 for theCompiler Compliance level. If the 2 drop-downs below that aren't 1.7, uncheck Use default compliance settings and set those to 1.7.

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:10178次
    • 积分:230
    • 等级:
    • 排名:千里之外
    • 原创:9篇
    • 转载:30篇
    • 译文:0篇
    • 评论:0条