POJ2353——Ministry

175 篇文章 0 订阅
Ministry
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4528 Accepted: 1452 Special Judge

Description

Mr. F. wants to get a document be signed by a minister. A minister signs a document only if it is approved by his ministry. The ministry is an M-floor building with floors numbered from 1 to M, 1<=M<=100. Each floor has N rooms (1<=N<=500) also numbered from 1 to N. In each room there is one (and only one) official.

A document is approved by the ministry only if it is signed by at least one official from the M-th floor. An official signs a document only if at least one of the following conditions is satisfied:
a. the official works on the 1st floor;
b. the document is signed by the official working in the room with the same number but situated one floor below;
c. the document is signed by an official working in a neighbouring room (rooms are neighbouring if they are situated on the same floor and their numbers differ by one).

Each official collects a fee for signing a document. The fee is a positive integer not exceeding 10^9.

You should find the cheapest way to approve the document.

Input

The first line of an input file contains two integers, separated by space. The first integer M represents the number of floors in the building, and the second integer N represents the number of rooms per floor. Each of the next M lines contains N integers separated with spaces that describe fees (the k-th integer at l-th line is the fee required by the official working in the k-th room at the l-th floor).

Output

You should print the numbers of rooms (one per line) in the order they should be visited to approve the document in the cheapest way. If there are more than one way leading to the cheapest cost you may print an any of them.

Sample Input

3 4
10 10 1 10
2 2 2 10
1 10 10 10

Sample Output

3
3
2
1
1

Hint

You can assume that for each official there always exists a way to get the approval of a document (from the 1st floor to this official inclusively) paying no more than 10^9.
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999

dp[i][j] = min(dp[i-1][j], dp[i][j-1], dp[i][j+1]) + mat[i][j]

方案可以递归输出

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 510;
const int M = 110;
const int inf = 0x3f3f3f3f;

int dp[M][N], mat[M][N];
int path[M][N];
int m, n, cnt;

void print(int i, int j)/*第i层第j个房间*/
{
	if (i == 1)
	{
		return;
	}
	if (path[i][j] == j)
	{
		print(i - 1, j);
		printf("%d\n", j);
	}
	else if (path[i][j] == j - 1)
	{
		print(i, j - 1);
		printf("%d\n", j - 1);
	}
	else
	{
		print(i, j + 1);
		printf("%d\n", j + 1);
	}
}

int main()
{
	while (~scanf("%d%d", &m, &n))
	{
		memset (dp, inf, sizeof(dp));
		for (int i = 1; i <= m; ++i)
		{
			for (int j = 1; j <= n; ++j)
			{
				scanf("%d", &mat[i][j]);
			}
		}
		for (int i = 1; i <= n; ++i)
		{
			dp[1][i] = mat[1][i];
			path[1][i] = i;
		}
		for (int i = 2; i <= m; ++i)
		{
			for (int j = 1; j <= n; ++j)
			{
				dp[i][j] = mat[i][j] + dp[i - 1][j];
				path[i][j] = j;
			}
			for (int j = 2; j <= n; ++j)
			{
				if (dp[i][j] > dp[i][j - 1] + mat[i][j])
				{
					dp[i][j] = dp[i][j - 1] + mat[i][j];
					path[i][j] = j - 1;
				}
			}
			for (int j = n - 1; j >= 1; --j)
			{
				if (dp[i][j] > dp[i][j + 1] + mat[i][j])
				{
					dp[i][j] = dp[i][j + 1] + mat[i][j];
					path[i][j] = j + 1;
				}
			}
		}
		int ans = inf, s;
		cnt = 0;
		for (int i = 1; i <= n; ++i)
		{
			if (ans > dp[m][i])
			{
				s = i;
				ans = dp[m][i];
			}
		}
		print(m, s);
		printf("%d\n", s);
	}
	return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、下 4载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、下载 4使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、下载 4使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值