1025. PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意:

编程能力测试是由浙江大学计算机科学与技术学院组织的。每个测试应该在几个地方同时运行,而名次列表将在测试后立即合并。现在,你的任务是编写一个程序来正确合并所有的排名列表并生成最终排名。
输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行包含一个正整数N(<=100),表示测试位置的数量。然后是N个排名列表,每个排名列表开始包含一个正整数K(<=300),是参加考试的人数,接下来是K行,每行包含注册号(13位数字)以及每一个考生的总分。一行上的数字都用空格隔开。
输出规格:
对于每个测试用例,首先在一行中打印所有的考生人数。然后以下列格式打印最终排名列表:
registration_number final_rank location_number local_rank
这些位置的编号从1到N。必须按最终等级的非递减顺序打印。相同分数的考生必须有相同的排名,并按其注册编号的非递减顺序打印。

代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct node
{
    char ID[20];
    int grade;
    int final_rank;
    int location_number;
    int local_rank;
}student[30010];
bool cmp(struct node a,struct node b)
{
    if(a.grade!=b.grade)
        return a.grade>b.grade;
    else
        return strcmp(a.ID,b.ID)<0;
}
int main()
{
    int i,j,n,m,k,t,l=0;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&m);
        t=l;
        for(j=0;j<m;j++)
        {
           scanf("%s %d",student[l].ID,&student[l].grade);
           student[l].location_number=i;
           l++;
        }
        sort(student+t,student+l,cmp);
        for(j=t;j<l;j++)
        {
            if(j==t)
            {
                student[j].local_rank=1;
            }
            else
            {
                if(student[j].grade==student[j-1].grade)
                {
                    student[j].local_rank=student[j-1].local_rank;
                }
                else
                {
                    student[j].local_rank=j-t+1;
                }
            }
        }
        /*for(j=t;j<l;j++)
        {
            printf("%s %d %d\n",student[j].ID,student[j].grade,student[j].local_rank);
        }*/
    }
    sort(student,student+l,cmp);
    for(i=0;i<l;i++)
    {
        if(i==0)
        {
           student[i].final_rank=1;
        }
        else
        {
            if(student[i].grade==student[i-1].grade)
            {
                student[i].final_rank=student[i-1].final_rank;
            }
            else
            {
                student[i].final_rank=i+1;
            }
        }
    }
    printf("%d\n",l);
    for(i=0;i<l;i++)
    {
       printf("%s %d %d %d\n",student[i].ID,student[i].final_rank,student[i].location_number,student[i].local_rank);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值