1042. Shuffling Machine (20)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目大意:

洗牌是一种随机抽取扑克牌的程序。因为标准的洗牌技术被认为是有缺点的,为了避免“内部工作”,员工与赌客合作进行不正当的洗牌,许多赌场使用自动洗牌机。你的任务是模拟一个洗牌机。
根据给定的随机顺序和重复次数,机器将54张牌洗牌。假设扑克牌的初始状态如下:
S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2


其中“S”代表“铲子”,,“H”代表“心”,“C”代表“俱乐部”,“D”代表“钻石”,“J”代表“小丑”。给定的顺序是[1,54]中不同证整数的排列。如果第i个位置上的数字为j,则意味着将卡从i位置上移动到j位置上。例如,假设我们只有5张牌:S3, H5, C1, D13 和 J2。给定一个洗牌顺序{4, 2, 5, 3, 1},结果将是:J2, H5, D13, S3, C1。如果我们再重洗一次牌,结果将是:C1, H5, S3, J2, D13。
输入规格:
每个输入文件包含一个测试用例。对于每个测试用例,第一行包含一个正整数K(<=20),即重复洗牌的次数。然后下一行包含给定的顺序。直线上得所有数字都用空格隔开。
输出规范:
对于每个测试用例,将洗牌的结果打印在一行中。所有的卡片都被一个空格隔开,并且在输出的结尾没有多余的空格。

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,n,m,k,t;
    int str[60],str1[60],str2[60];
    scanf("%d",&n);
    for(i=1;i<=54;i++)
    {
        scanf("%d",&str[i]);
        str2[i]=i;
    }
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=54;j++)
           str1[str[j]]=str2[j];
        for(j=1;j<=54;j++)
            str2[j]=str1[j];
    }
    for(i=1;i<=54;i++)
    {

        if(i!=1)
            printf(" ");
            if(str2[i]>=1&&str2[i]<=13)
            {
                printf("S%d",str2[i]);
            }
            else if(str2[i]>=14&&str2[i]<=26)
            {
                printf("H%d",str2[i]-13);
            }
            else if(str2[i]>=27&&str2[i]<=39)
            {
                printf("C%d",str2[i]-26);
            }
            else if(str2[i]>=40&&str2[i]<=52)
            {
                printf("D%d",str2[i]-39);
            }
            else if(str2[i]>=53&&str2[i]<=54)
            {
                printf("J%d",str2[i]-52);
            }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值