Message Flood

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

示例输出

3

来源



#include <iostream>
#include<string>
#include<algorithm>
#include<memory.h>
using namespace std;
bool cmp(string a,string b)//字符串的比较;
{
    return a<b;//升序比较;
}
string name[20001],t;//string定义字符串变量;
bool found [20001];
int n,m;
bool bi_search()//二分法查找;
{
    int start=0,mid,end=n-1;
    while(start<=end)
    {
        mid=(start+end)/2;
        if(t==name[mid])
        {
            if(!found[mid])
            {


            found[mid]=true;//查找到;
            return true;
            }
        else
            return false;
        }
        else if(t<name[mid])//前端查找;
            end=mid-1;
        else//后端查找;
            start=mid+1;
    }
    return false;
}
int main()
{
    int i,count;//统计剩下的人名;
    while(cin>>n&&n)
    {
        cin>>m;
        memset(found,false,sizeof(found));
        //memset(found,false,20001*sizeof(bool);//初始化;
        for(i=0;i<n;i++)
        {
            cin>>name[i];
            for(int j=0;j<name[i].length();j++)
                if(name[i][j]>='A'&&name[i][j]<='Z')
                name[i][j]+=32;
               // name[i][j]=tolower(name[i][j]);//将大写字符变为小写字符;
        }
        count=n;
        sort(name,name+n,cmp);//按照字典序升序排列;
        for(i=0;i<m;i++)
        {
            cin>>t;
            for(int j=0;j<t.length();j++)
                t[j]=tolower(t[j]);//将大写字符变为小写字符;
            if(bi_search())
                count--;
        }
       cout<<count<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值