费马小定理+逆元(模板)


A - A
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15


F。模板题
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
#include<vector>  
#include<string>  
#include<iostream>  
#include<queue>  
#include<cmath>  
#include<map>  
#include<stack>  
#include<set>  
using namespace std;  
const int INF=0x3f3f3f3f;  
typedef long long LL;  
const int mod=1e6+3;  
const int maxn=1e6+100;  
LL fac[maxn],inv[maxn];  
LL Pow(LL a,LL b)  
{  
    LL ans=1;  
    while(b)  
    {  
        if(b&1)  
            ans=(ans*a)%mod;  
        a=(a*a)%mod;  
        b>>=1;  
    }  
    return ans;  
}  
int main()  
{  
    int cas=0;  
    int n,a,b;  
    fac[0]=inv[0]=1;  
    for(int i=1;i<=1000000;i++)  
    {  
        fac[i]=(fac[i-1]*i)%mod; //对阶乘打表 
        inv[i]=Pow(fac[i],mod-2);  
    }  
    scanf("%d",&n);  
    while(n--)  
    {  
        scanf("%d%d",&a,&b);  
        LL ans=fac[a]*inv[b]%mod*inv[a-b]%mod;  
        printf("Case %d: %lld\n",++cas,ans);  
    }  
    return 0;  
}  

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值