hdu 2017 字符串统计

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2017

字符串统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47754    Accepted Submission(s): 26358


Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
 

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
 

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
 

Sample Input
  
  
2 asdfasdf123123asdfasdf asdf111111111asdfasdfasdf
 

Sample Output
  
  
6 9
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2024  1096  1090  1095  1091 
 

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN = 1010;

int main()
{
    int T, iNum, i;
    char str[MAXN];
    scanf("%d", &T);
    while(T--)
    {
        iNum = 0, i = 0;
        scanf("%s", str);
        while(str[i] != '\0')
        {
            if(str[i] >= '0' && str[i] <= '9')
                iNum++;
            ++i;
        }
        printf("%d\n", iNum);
        str[0] = '\0';
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值