Uva 113 Power of Cryptography

 Power of Cryptography 

Background

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

The Problem

Given an integer tex2html_wrap_inline32 and an integertex2html_wrap_inline34 you are to write a program that determinestex2html_wrap_inline36 , the positivetex2html_wrap_inline38 root ofp. In this problem, given such integers n and p, p will always be of the formtex2html_wrap_inline48 for an integerk (this integer is what your program must find).

The Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairstex2html_wrap_inline56 ,tex2html_wrap_inline58 and there exists an integerk, tex2html_wrap_inline62 such thattex2html_wrap_inline64 .

The Output

For each integer pair n and p the value tex2html_wrap_inline36 should be printed, i.e., the numberk such that tex2html_wrap_inline64 .

Sample Input

2
16
3
27
7
4357186184021382204544

Sample Output

4
3
1234

题目大意:

tex2html_wrap_inline56 ,tex2html_wrap_inline58

计算tex2html_wrap_inline36


#include<stdio.h>  
#include<math.h>  

int main(void)  
{  
	double n, p;  
	while(scanf("%lf%lf", &n, &p) != EOF)  
	{  
		printf("%.0lf\n", pow(p, 1/n));  
	}  
	return 0;  
}  

float和double的范围和精度。

1. 范围
  float和double的范围是由指数的位数来决定的。
  float的指数位有8位,而double的指数位有11位,分布如下:
  float:
  1bit(符号位) 8bits(指数位)23bits(尾数位)
  double:
  1bit(符号位) 11bits(指数位)52bits(尾数位)
  于是,float的指数范围为-127~+128,而double的指数范围为-1023~+1024,并且指数位是按补码的形式来划分的。
  其中负指数决定了浮点数所能表达的绝对值最小的非零数;而正指数决定了浮点数所能表达的绝对值最大的数,也即决定了浮点数的取值范围。
  float的范围为-2^128 ~+2^128,也即-3.40E+38 ~ +3.40E+38;double的范围为-2^1024 ~+2^1024,也即-1.79E+308 ~ +1.79E+308。

2.  精度
  float和double的精度是由尾数的位数来决定的。浮点数在内存中是按科学计数法来存储的,其整数部分始终是一个隐含着的“1”,由于它是不变的,故不能对精度造成影响。
  float:2^23 =8388608,一共七位,这意味着最多能有7位有效数字,但绝对能保证的为6位,也即float的精度为6~7位有效数字;
  double:2^52 =4503599627370496,一共16位,同理,double的精度为15~16位。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值