Background
One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)
At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a snake.
For example, her first 25 seconds went like this:
( the numbers in the grids stands for the time when she went into the grids)
25 | 24 | 23 | 22 | 21 |
10 | 11 | 12 | 13 | 20 |
9 | 8 | 7 | 14 | 19 |
2 | 3 | 6 | 15 | 18 |
1 | 4 | 5 | 16 | 17 |
5
4
3
2
1
1 2 3 4 5
At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).
Your task is to decide where she was at a given time.
(you can assume that M is large enough)
Input
Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.
Output
For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.
Sample Input
8
20
25
0
Sample Output
2 3
5 4
1 5
题目大意:
给你一个足够大的棋盘,有一只蚂蚁按照一定的方式走,问你在时间t,它的坐标是多少。
走的方式是,一上,一右,一下,一右,二上,二左……如蛇形盘绕。
如果我们从对角线看呢,1 3 7 13 21
公差是1 2 4 6 8 首项为1,公差为2的等差数列的前n项和。
首先找出对应的位置,用Lower_bound()找出的是位置pos,但是可能的位置是pos,pos-1,判断是这两个位置的哪一个,然后分奇数偶数处理。
#include<iostream>
#include<string>
#include<math.h>
using namespace std;
int main() {
int n;
while(cin >> n) {
if(n == 0) {
break;
}
int c = (int)ceil(sqrt(n));
int pos = (c-1)*c+1;
int step; // 距离差
step = n - pos;
if( (c+1)%2 == 0) { //如果是奇数的话记录下 n和pos的距离差
if(step > 0) {
cout<<c-step<<" "<<c<<endl;
}
else {
cout<<c<<" "<<c+step<<endl;
}
}
else {
if(step > 0) {
cout<<c<<" "<<c-step<<endl;
}
else {
cout<<c+step<<" "<<c<<endl;
}
}
}
return 0;
}