Time Limit:3000MS | Memory Limit:Unknown | 64bit IO Format:%lld & %llu |
Description
Problem B - Generalized Matrioshkas
Problem B - Generalized Matrioshkas |
Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll inside. Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.
Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.
Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented by m we find the toys represented by n1, n2, ..., nr, it must be true that n1 + n2 + ... + nr < m. And if this is the case, we say that toy mcontains directly the toys n1, n2, ..., nr . It should be clear that toys that may be contained in any of the toys n1, n2, ..., nr are not considered as directly contained in the toy m.
A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:
For example, the sequence
On the other hand, the following sequences do not describe generalized matrioshkas:
-
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9because toy 2 is bigger than toy 1 and cannot be allocated inside it.
-
-9 -7 -2 2 -3 -2 -1 1 2 3 7 -2 2 9because 7 and 2 may not be allocated together inside 9.
-
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9because there is a nesting problem within toy 3.
Your problem is to write a program to help Vladimir telling good designs from bad ones.
Input
The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than 107.
Output
Output texts for each input case are presented in the same order that input is read.
For each test case the answer must be a line of the form
:-) Matrioshka!
if the design describes a generalized matrioshka. In other case, the answer should be of the form
:-( Try again.
Sample Input
-9 -7 -2 2 -3 -2 -1 1 2 3 7 9 -9 -7 -2 2 -3 -1 -2 2 1 3 7 9 -9 -7 -2 2 -3 -1 -2 3 2 1 7 9 -100 -50 -6 6 50 100 -100 -50 -6 6 45 100 -10 -5 -2 2 5 -4 -3 3 4 10 -9 -5 -2 2 5 -4 -3 3 4 9
Sample Output
:-) Matrioshka! :-( Try again. :-( Try again. :-) Matrioshka! :-( Try again. :-) Matrioshka! :-( Try again.
题目大意:
给你一组俄罗斯套娃,大的娃娃内部可以放小的娃娃,内部娃娃的尺寸严格小于外部的尺寸。
解题思路:
(1) 类似于括号匹配,判断一个序列必须满足左右存在匹配
(2) 如果内部大于外部,或者结束时栈不为空就输出
:-( Try again.
(3) 初始化两个栈st1,st2
st1用于进行栈操作,st2用保存辖域内套娃的大小
(4) 每次左右匹配时,先将st1弹出,我们可以将该娃娃的大小赋值给栈内前一个st2,保存起来。因为前一个娃娃还未匹配,他一定是套在当前这个娃娃的外面一层。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
const int N = 5000;
long long num[N],st1[N],st2[N];
int main() {
char ch;
int cut = 1;
while(scanf("%lld",&num[cut]) != EOF) {
memset(st1,0,sizeof(st1));
memset(st2,0,sizeof(st2));
ch = getchar();
if(ch == '\n') {
int top = 1;
st1[1] = num[1];
int i;
for( i = 2; i <= cut; i++) {
if(st1[top] + num[i] == 0) {
top--;
st2[top] += abs(num[i]);
if(top and abs(st2[top]) >= abs(st1[top])) {
break;
}
}
else {
top++;
st1[top] = num[i];
st2[top] = 0;
}
}
if(top) {
printf(":-( Try again.\n");
}
else {
printf(":-) Matrioshka!\n");
}
cut = 1;
}
else {
cut++;
}
}
return 0;
}