Uva 846 Steps

 Steps 

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output 

Input consists of a line containing n, the number of test cases. Foreach test case, a line follows with two integers: 0$ \le$x$ \le$y < 231.For each test case, print a line giving the minimum number of steps toget from x to y.

Sample Input 

3
45 48
45 49
45 50

Sample Output 

3
3
4

题意: 有t组测试数据。要求为最少步得到给出的整数n。步长要求为:起步和停止的步长为一,每次只能在上次的基础上增加一,减少一或者不变。

先计算出两点间的长度d

因为是对称的从两边开始,依次往中间逼近 step++,用距离 d -= step 直到 d < 0

#include<stdio.h>
#include<string.h>

int main() {
	int t;
	while(scanf("%d",&t) != EOF) {
		int x,y;
		int d;
		while(t--) {
			scanf("%d%d",&x,&y);
			int step=1,count=0;
			d=y-x;
			int ans=0;
			while(d>0) {
				d -= step;
				ans++;
				if(count)
					step++;
				count = !count;
			}
			printf("%d\n",ans);
		}	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值