UVA - 465 Overflow

 Overflow 

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big


题意:

输入两个数和一个运算符

判断前面输入的两个数,和结果。是否超过int型的最大值

如果第一个数超过输出 first number too big

第二个超过输出second number too big

结果超过输出result too big


解析:

直接用字符串输入,然后用atof函数转化为double型就可以解决了。


#include <stdio.h>
#include <string.h>
#include <stdlib.h>

const int MAX = 2147483647;
const int N = 1000;
int main() {
	char str1[N], str2[N], op; 
	while (scanf("%s %c %s", str1, &op, str2) != EOF) { 
		printf("%s %c %s\n", str1, op, str2);
		if (atof(str1) > MAX)
			printf("first number too big\n"); 
		if (atof(str2) > MAX)
			printf("second number too big\n"); 
		if ( (op == '+' && atof(str1) + atof(str2) > MAX) || (op == '*' && atof(str1) * atof(str2) > MAX))
			printf("result too big\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值