UVA - 465 Overflow

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big
 
  
 
  
 
  
 
  
 
  
分析:
解法1:
大数模板。
代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <climits>
using namespace std;


#define maxn 30000


struct bign
{
    int len, s[maxn];


    bign()
    {
        memset(s, 0, sizeof(s));
        len = 1;
    }
    
    bign(int num)
    {
        *this = num;
    }
    
    bign(const char* num) 
    {
        *this = num;
    }
    
    bign operator = (int num) 
    {
        char s[maxn];
        sprintf(s, "%d", num);
        *this = s;
        return *this;
    }
    
    bign operator = (const char* num) 
    {
        len = strlen(num);
        for (int i = 0; i < len; i++) s[i] = num[len-i-1] - '0';
        return *this;
    }
    
    string str() const 
    {
        string res = "";
        for (int i = 0; i < len; i++) res = (char)(s[i] + '0') + res;
        if (res == "") res = "0";
        return res;
    }
    
    bign operator + (const bign& b) const
    {
        bign c;
        c.len = 0;
        for (int i = 0, g = 0; g || i < max(len, b.len); i++) 
        {
            int x = g;
            if (i < len) x += s[i];
            if (i < b.len) x += b.s[i];
            c.s[c.len++] = x % 10;
            g = x / 10;
        }
        return c;
    }
    
    void clean() 
    {
        while(len > 1 && !s[len-1]) len--;
    }
    
    bign operator * (const bign& b) 
    {
        bign c; c.len = len + b.len;
        for (int i = 0; i < len; i++)
        for (int j = 0; j < b.len; j++)
        c.s[i+j] += s[i] * b.s[j];
        for (int i = 0; i < c.len-1; i++)
        {
            c.s[i+1] += c.s[i] / 10;
            c.s[i] %= 10;
        }
        c.clean();
        return c;
    }
    
    bign operator - (const bign& b) 
    {
        bign c; c.len = 0;
        for (int i = 0, g = 0; i < len; i++) 
        {
            int x = s[i] - g;
            if (i < b.len) x -= b.s[i];
            if (x >= 0) 
                g = 0;
            else 
            {
                g = 1;
                x += 10;
            }
            c.s[c.len++] = x;
        }
        c.clean();
        return c;
    }
    
    bool operator < (const bign& b) const
    {
        if (len != b.len) return len < b.len;
        for (int i = len-1; i >= 0; i--)
        if (s[i] != b.s[i]) return s[i] < b.s[i];
        return false;
    }
    
    bool operator > (const bign& b) const
    {
        return b < *this;
    }
    
    bool operator <= (const bign& b) 
    {
        return !(b > *this);
    }
    
    bool operator == (const bign& b) 
    {
        return !(b < *this) && !(*this < b);
    }
    
    bool operator != (const bign& b) 
    {
        return (b < *this) || (*this < b);
    }
    
    bign operator += (const bign& b) 
    {
        *this = *this + b;
        return *this;
    }
};


istream& operator >> (istream &in, bign& x) 
{
    string s;
    in >> s;
    x = s.c_str();
    return in;
}


ostream& operator << (ostream &out, const bign& x) 
{
    out << x.str();
    return out;
}


int main() 
{
      bign a, c, Max = INT_MAX;
      char b;
      while (cin >> a >> b >> c)
      {
        cout << a << ' ' << b << ' ' << c << endl;
        a.clean(), c.clean();
        if (a > Max)
            cout << "first number too big" << endl;
        if (c > Max)
            cout << "second number too big" << endl;
        if (b == '+')
            if (a+c > Max)
                cout << "result too big" << endl;
        if (b == '*')
            if (a*c > Max)
                cout << "result too big" << endl;
    }
}
 
  
 
  
 
  
 
  
解法2:

更简单的解法,用浮点数瞬间秒杀。

用atof将string转为float/double.

float的范围为-2^128 ~ +2^127,也即-3.40E+38 ~ +3.40E+38;

double的范围为-2^1024 ~ +2^1023,也即-1.79E+308 ~ +1.79E+308。

int最大值为INT_MAX(定义在<climits>),为2147483647,即0x7fffffff.

代码:
#include <cstdio>
#include <cstdlib>
#include <climits>


char num1[300],num2[300];
int main()
{
    char  c;
    while (scanf("%s %c %s", num1, &c, num2) != EOF)
    {
        printf("%s %c %s\n", num1, c, num2);
        double a = atof(num1);
        double b = atof(num2);
        if (a > INT_MAX)                 printf("first number too big\n");
        if (b > INT_MAX)                 printf("second number too big\n");
        if (c == '+' && a+b > INT_MAX)    printf("result too big\n");
        if (c == '*' && a*b > INT_MAX)     printf("result too big\n");
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值