UVA 10341 Solve It (解方程 二分查找+精度)

Solve It

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-xq*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554

题目大意:给你p,q,r,s,t,u六个变量的数值,要求你求出在区间(1,0)内,求x的值。

解析:对函数求导后导函数>0,可得函数在(1,0)上是单调递增的,所以直接用二分查找法求解。


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
using namespace std;
double p,q,r,s,t,u;
double f(double x) {
	double result = p*exp(-x) + q*sin(x) + r*cos(x) + s*tan(x) + t*x*x + u;
	return result;
}
int main() {
	double ans;	
	double result;
	while(scanf("%lf %lf %lf %lf %lf %lf",&p,&q,&r,&s,&t,&u) != EOF) {
		double mid,left,right;
		left = 0, right = 1;
		if( f(left) * f(right) > 0) {
			printf("No solution\n");
			continue;	
		}
		while(left < right) {
			mid = (left + right) / 2;
			result = f(mid);
			if(fabs(result) < 1e-6) {
				printf("%.4lf\n",mid);
				break;
			}
			if( result > 0) {
				left = mid;
			}
			else {
				right = mid;
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值