Solve It
Input:standard input
Output:standard output
Time Limit: 1 second
Memory Limit: 32 MB
Solve the equation:
p*e-x+q*sin(x) + r*cos(x) + s*tan(x) +t*x2 + u = 0
where 0 <= x <= 1.
Input
Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line:p, q,r, s,t and u (where0 <= p,r <= 20 and-20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.
Output
For each set of input, there should be a line containing the value ofx, correct upto 4 decimal places, or the string "No solution", whichever is applicable.
Sample Input
0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1
Sample Output
0.7071
No solution
0.7554
题目解析:
首次,遇到二分求方程。第一次没求出来,之后经同学指点之后就连续A了两道。挺爽的^O^。题目说给出p,q,r,s,u五个系数,叫你求出方程的解。
思路解析:
我们在中学的时候就学过了,二分迭代求值。因此,我们可以从中入手。即,当f(x1)*f(x2) <= 0时,方程必有解。OK,既然我们解决了判断方程是否有解,但是要如何得到解呢?显然,我们可以根据我们刚才说的二分迭代。我们可以根据高等数学中的知识,可以判断出一个方程的单调性。因此,之后可以根据单调性的情况进行很好的二分。
下面我们根据函数的不同单调性来给出不同的判断条件:
单调递增:
mid = (x1+x2)/2;
-------->f(mid) < 0 x1 = mid;
-------->f(mid) > 0 x2 = mid;
例如,假如要求的解为2。
单调递减:
mid = (x1+x2)/2;
-------->f(mid) > 0 x1 = mid;
------->f(mid) < 0 x2 = mid;
例如,假如要求的解为4。
OK。基本算法就这些了。别的就是处理的细节问题了。然后,这题还要注意e^x的函数表示,我刚开始的时候,并不知道要如何表示后来才知道e^x = exp(x);别的自己看代码吧。
#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const double EPS = 1e-14;
double p,q,r,s,t,u;
double Check(double x)
{
double y;
y = p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
return y;
}
int main()
{
while(scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)!=EOF)
{
double x1 = 0.0,x2 = 1.0;
if(Check(x1)*Check(x2)<=EPS){
double mid;
while(x2-x1>EPS)
{
mid = (x1+x2)/2.0;
if(Check(mid) < 0)
x2 = mid;
else
x1 = mid;
}
printf("%.4lf\n",mid);
}else
{
printf("No solution\n");
}
}
return 0;