关闭

ubuntu下编译qt-4.7.4

347人阅读 评论(0) 收藏 举报
分类:


下载源码,解压

./configure  -nomake examples -nomake docs -nomake demos  -make tools -make libs -audio-backend -phonon -phonon-backend -qt-zlib -qt-gif -qt-libtiff -qt-libpng -qt-libjpeg -qt-libmng  -opengl


sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

 

opengl需要
sudo apt-get install libgl1-mesa-dev libglu1-mesa-dev


下面的为gstreamer需要使用的头文件等
sudo apt-get install libglib2.0-dev
sudo apt-get install libgstreamer0.10-dev
sudo apt-get install libgstreamer-plugins-base0.10-dev
sudo apt-get install libxml-dev  (无法)

安装各类需要使用到的开发包
sudo apt-get install xorg-dev

sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:22952次
    • 积分:566
    • 等级:
    • 排名:千里之外
    • 原创:32篇
    • 转载:13篇
    • 译文:1篇
    • 评论:0条