hdu 1158(DP)

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
  
  
3 4 5 6 10 9 11 0
 

Sample Output
  
  
199
解题思路:这道题目的状态其实很明显,dp[i][j]表示第i个月一共找了j个人,那么 dp[i][j] = min{dp[i-1][k] + (j-k)*fire + j*salary} or dp[i][j]=min{dp[i-1][k] + (k - j)*hire + j*salary}。。。
不知道为什么会WA,别人和我一样的思路却能够AC。。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int inf = 0x7ffffff;
int n,h,f,s;
int work[13],dp[13][110];

int main()
{	
	while(scanf("%d",&n)!=EOF && n)
	{
		int maximum = 0;
		scanf("%d%d%d",&h,&s,&f);
		for(int i = 1; i <= n; i++)
		{
			scanf("%d",&work[i]);
			maximum = max(maximum,work[i]);
		}
		for(int i = work[1]; i <= maximum; i++)
			dp[1][i] = i * (h + s);
		for(int i = 2; i <= n; i++)
			for(int j = work[i]; j <= maximum; j++)
				for(int k = work[i-1]; k <= maximum; k++)
				{
					if(k > j)
						dp[i][j] = min(dp[i][j],dp[i-1][k] + (k - j) * f + j * s);
					else
						dp[i][j] = min(dp[i][j],dp[i-1][k] + (j - k) * h + j * s);
				}
		int ans = inf;
		for(int i = work[n]; i <= maximum; i++)
			ans = min(ans,dp[n][i]);
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值