HDU - 1025 Constructing Roads In JGShining's Kingdom (nlogn 最长上升子序列)

Constructing Roads In JGShining’s Kingdom HDU - 1025
JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

这里写图片描述
In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample.
You should tell JGShining what’s the maximal number of road(s) can be built.

Sample Input

2
1 2
2 1
3
1 2
2 3
3 1

Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

题意:问可以建立多少条不相交的路

分析:一开始以为是二分图,不过不能同边的点太多。
画图发现就是求最长上升子序列,不过n有500000所以要用 nlogn的方法。
也就是不记录哪些符合要求,只记录符合要求的有多少个,用一个dp数组记录原始数据,用一个数组a[]记录。
二分查找a里面是否有比dp[i]大的,然后用dp[i]替换第一个比它大的a,如果没有那么len++并且a[len]=dp[i]; 那么最后len就是我们要的答案啦。
AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[505000];
int w[505000];
int lis(int n)
{
    int len=1;
    w[1]=dp[1];
    for(int i=2;i<=n;i++)
    {
        int right=len;
        int left=1;
        while(left<=right)
        {
            int mid=(left+right)>>1;
            if(dp[i]>w[mid])
            left=mid+1;
            else
            right=mid-1;
        }
        w[left]=dp[i];
        if(left>len)
        len=left;
    }
    return len;
}
int main()
{
    int n,cas=0;;
    while(scanf("%d",&n)==1)
    {
        for(int i=0;i<n;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            dp[a]=b;
        }
        int ans=lis(n);
        printf("Case %d:\n",++cas);
        if(ans==1)
        printf("My king, at most 1 road can be built.\n\n");
        else
        printf("My king, at most %d roads can be built.\n\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值