HOJ 1640 Mobile Phone

Mobile Phone

My Tags  (Edit)
Source : IOI 2001
Time limit : 5 secMemory limit : 32 M

Submitted : 1025, Accepted : 304

PROBLEM

 

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S´S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

 

INPUT AND OUTPUT

 

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input contains multiple test cases. Each test case is encoded as follows. Every instruction comes on a separate line, and consists of one instruction id and a number of parameter integers according to the following table.

 

Instruction

Parameters

Meaning

0

S

Initialize the matrix size to S´S containing all zeros. This instruction is given only once and it will be the first instruction.

1

X Y A

Add A to the number of active phones in table square (XY). Amay be positive or negative.

2

L B R T

Query the current sum of numbers of active mobile phones  in squares (X,Y), where L £ X £ RB £ Y £ T

3

 

Terminate program. This instruction is given only once and it will be the last instruction.

 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4´4, we have 0 £ X £ 3 and 0 £ Y £ 3.

 

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

 

There are multiple test cases, process to the end of file.

CONSTRAINTS

 

Table size

S´S

1´1 £ S´S £ 1024´1024

Cell value V at any time

V

0 £ V £ 215 –1  (= 32767)

Update amount

A

- 215 £ A £ 215–1  (= 32767)

No of instructions in input

U

3 £ U £ 60002

Maximum number of phones in the whole table

M

M= 230

 

Sample Input

0 41 1 2 32 0 0 2 21 1 1 21 1 2 -12 1 1 2 33

Sample Output

34


题目大意:一个矩阵,给一些命令,命令1:在某些位置上进行加减操作;命令2:查询某块区域内元素之和是多少。

大致思路:乍一看题目感觉很水,因为完全没有什么难度,就按照题目思路一步步完成,提交上去发现超时,因为矩阵很大,可能查询命令比较多。所以不能用常规的方法来做,需要用树状数组来完成,而这里就是一个二维的树状数组。对于树状数组,具体内容请自行百度,简单来说,就是将存储与查询的时间复杂度都变成O(lgn) ,而之前存储的复杂度是O(1),查询的复杂度是O(n^n)。

代码如下:

#include <iostream>
#include <string.h>
#define lowbit(x) (x&-x)
using namespace std;
int base[1200][1200];

int sum(int x,int y)
{
    int res=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            res += base[i][j];
    return res;
}

int main()
{
    int order,i,j,n,x1,y1,x2,y2,num;

    while(cin>>order)
    {
        if(order==0)
        {
            memset(base,0,sizeof(base));
            cin>>n;
        }
        else if(order == 1)
        {
            cin>>x1>>y1>>num;
            for(i=x1+1;i<=n;i+=lowbit(i))
                for(j=y1+1;j<=n;j+=lowbit(j))
                    base[i][j] += num;
        }
        else if(order == 2)
        {
            cin>>x1>>y1>>x2>>y2;
            cout<<sum(x2+1,y2+1)-sum(x1,y2+1)-sum(x2+1,y1)+sum(x1,y1)<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值