hdu 1164 Eddy's research I

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7342    Accepted Submission(s): 4439


Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he
艾迪的兴趣是非常广泛的,最近他感兴趣的是素数.艾迪想找到所有可以被素数整除的数.但是他写不出这个程序。
can't write program, so Eddy has to ask intelligent you to help him,  
所以艾迪请求你帮他解决这个素数,
 he asks you to write a program which can do the number to divided into the multiply of prime number  factor .
他要求你把这个数分解成多个素数的积
 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 输入将包含一个数字1 < x < = 65535每行代表的数量的元素集

Output
You have to print a line in the output for each entry with the answer to the previous question.
 每个题的答案在单独的一行输出

Sample Input
  
  
11 9412
 

Sample Output
  
  
11 2*2*13*181
 

Author
eddy
 
import java.util.Scanner;

public class p1164 {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int[] primes = new int[7000];// 打表法
		primes[0] = 2;
		primes[1] = 3;
		primes[2] = 5;
		primes[3] = 7;
		int count = 4;
		for (int i = 11; i <= 65535; i += 2) {// 65535--素数个数为6542个
			boolean isPrime = true;
			for (int j = 0; primes[j] * primes[j] <= i && primes[j] != 0; j++) {
				if (i % primes[j] == 0) {
					isPrime = false;
					break;
				}
			}
			if (isPrime) {
				primes[count++] = i;
			}
		}
		String result = "";
		boolean isFirst;
		while (sc.hasNext()) {
			int x = sc.nextInt();
			result = "";
			isFirst = true;
			for (int i = 0; primes[i] <= x; i++) {
				if (x % primes[i] == 0) {
					if (isFirst) {
						result += primes[i];
						isFirst = false;
					} else {
						result += "*" + primes[i];
					}
					x /= primes[i];
					i = -1;
				}
			}
			System.out.println(result);
		}
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值