最大堆 最小堆 poj2442 STL堆的使用

最大堆最小堆代码实现

http://blog.csdn.net/xiaoxiaoxuewen/article/details/7570621

最大堆 最小堆原理图

http://www.cnblogs.com/wu8685/archive/2010/12/30/1922218.html

STL 的堆操作

http://hi.baidu.com/solofancy/item/14acd02b9743f7d30f37f927 

http://blog.csdn.net/morewindows/article/details/6967409


STL 的堆操作  来自上面的博客  

STL里面的堆操作一般用到的只有4个:make_heap();、pop_heap();、push_heap();、sort_heap();
他们的头文件函数是#include <algorithm>


首先是make_heap();
他的函数原型是:void make_heap(first_pointer,end_pointer,compare_function);
一个参数是数组或向量的头指针,第二个向量是尾指针。第三个参数是比较函数的名字。在缺省的时候,默认是大跟堆。(下面的参数都一样就不解释了)
作用:把这一段的数组或向量做成一个堆的结构。范围是(first,last)

然后是pop_heap();

它的函数原型是:void pop_heap(first_pointer,end_pointer,compare_function);

作用:pop_heap()不是真的把最大(最小)的元素从堆中弹出来。而是重新排序堆。它
把first和last交换,然后将[first,last-1)的数据再做成一个堆。

接着是push_heap() void pushheap(first_pointer,end_pointer,compare_function);

作用:push_heap()假设由[first,last-1)是一个有效的堆,然后,再把堆中的新元素加
进来,做成一个堆。

最后是sort_heap()void sort_heap(first_pointer,end_pointer,compare_function);

作用是sort_heap对[first,last)中的序列进行排序。它假设这个序列是有效堆。(当然
,经过排序之后就不是一个有效堆了)

实例:

#include<algorithm>
#include<cstdio>
using namespace std;
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int i,number[20]={29,23,20,22,17,15,26,51,19,12,35,40};	
	make_heap(&number[0],&number[12]);	
	//结果是:51 35 40 23 29 20 26 22 19 12 17 15	
	for(i=0;i<12;i++)		
		printf("%d ",number[i]);
	printf("\n");	
	make_heap(&number[0],&number[12],cmp);
	//结果:12 17 15 19 23 20 26 51 22 29 35 40
	for(i=0;i<12;i++)		
		printf("%d ",number[i]);	
	printf("\n");	
	//加入元素8	
	number[12]=8;	
	//加入后调整	
	push_heap(&number[0],&number[13],cmp);	
	//结果:8 17 12 19 23 15 26 51 22 35 40 20	
	for(i=0;i<13;i++)		
		printf("%d ",number[i]);	
	printf("\n");	
	//弹出元素8	
	pop_heap(&number[0],&number[13],cmp);	
	//结果:12 17 15 19 23 20 26 51 22 29 35 40	
	for(i=0;i<13;i++)		
		printf("%d ",number[i]);	
	printf("\n");	
	sort_heap(&number[0],&number[12],cmp);	
	//结果不用说都知道是有序的了!	
	for(i=0;i<12;i++)		
		printf("%d ",number[i]);	
	return 0;	
}




应用

POJ 2442  http://poj.org/problem?id=2442

Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 5910 Accepted: 1813

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

Source

POJ Monthly,Guang Lin

给你n*m的矩阵,然后每行取一个元素,组成一个包含n个元素的序列,一共有n^m种序列,

让你求出序列和最小的前n个序列的序列和。

思路  :

来自下面的博客

http://www.cnblogs.com/vip-wy/archive/2012/02/15/2353064.html

解题步骤:

1.将第一序列读入data1向量中,并按升序排序。

2.将数据读入data2向量中,并按升序排序。

    将data2[0] + data1[i] ( 0<=i<=n-1)读入dataq向量中

    用make_heap对dataq建堆。

    然后data2[1] + data1[i] (0<=i<=n-1),如果data2[1] + data1[i]比堆dataq的顶点大,则退出,否则删除

    堆的顶点,插入data2[1] + data1[i]。然后是data2[2],...data2[n - 1]

 3.将dataq的数据拷贝到data1中,并对data1按升序排序

 4.循环2,3步,直到所有数据读入完毕。

 5.打印data1中的数据即为结果。

#include<cstdio>
 #include<algorithm>
 #include<iostream>
 #define Max 2008
 using namespace std;
 int a[Max],b[Max],sum[Max];
 int main()
 {
     int i,j,k,t,m,n,temp;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%d %d",&m,&n);
         for(i=0;i<n;i++)
             scanf("%d",&a[i]);
         for(i=1;i<m;i++)
         {
             sort(a,a+n);
             for(j=0;j<n;j++)
                 scanf("%d",&b[j]);
             sort(b,b+n);
             for(j=0;j<n;j++)
                 sum[j]=a[j]+b[0];
             make_heap(sum,sum+n);
             for(j=1;j<n;j++)
             {
                 for(k=0;k<n;k++)
                 {
                     temp=a[k]+b[j];
                     if(temp>=sum[0])
                         break;
                     pop_heap(sum,sum+n);
                     sum[n-1]=temp;
                     push_heap(sum,sum+n);
                 }
             }
             for(j=0;j<n;j++)
                     a[j]=sum[j];
         }
         sort(a,a+n);
         for(j=0;j<n-1;j++)
             printf("%d ",a[j]);
         printf("%d\n",a[j]);
     }return 0;
 }


解题参考  :  http://www.cnblogs.com/vip-wy/archive/2012/02/15/2353064.html


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值