ZOJ 1965 Build The Electric System

这是一道关于计算重建受损电力系统最小成本的问题。在一场大雪后,中国的南方地区电力系统受到严重破坏,需要尽快恢复。题目要求编写程序,确保每个村庄之间至少有一条电力线路,并给出重建线路的最小花费。输入包含多个测试用例,每个用例包含村庄数量、原有线路数量以及每条线路的状态(是否损坏及修复成本)。输出为恢复电力系统的最小总成本。
摘要由CSDN通过智能技术生成

浙江大学OJ果然难一些,数据更加严格啊!在杭电上写的一些AC的程序在这里就是WA,以后编程一定要多注意细节,细节决定成败。加油!!!

In last winter, there was a big snow storm in South China. The electric system was damaged seriously. Lots of power lines were broken and lots of villages lost contact with the main power grid. The government wants to reconstruct the electric system as soon as possible. So, as a professional programmer, you are asked to write a program to calculate the minimum cost to reconstruct the power lines to make sure there's at least one way between every two villages.

Input

Standard input will contain multiple test cases. The first line of the input is a single integerT (1 <=T <= 50) which is the number of test cases. And it will be followed byT consecutive test cases.

In each test case, the first line contains two positive integers N andE (2 <=N <= 500, N <= E <= N * (N - 1) / 2), representing the number of the villages and the number of the original power lines between villages. There followE lines, and each of them contains three integers,A, B,K (0 <= A, B < N, 0 <=K < 1000). A and B respectively means the index of the starting village and ending village of the power line. IfK is 0, it means this line still works fine after the snow storm. IfK is a positive integer, it means this line will cost K to reconstruct. There will be at most one line between any two villages, and there will not be any line from one village to itself.

Output

For each test case in the input, there's only one line that contains the minimum cost to recover the electric system to make sure that there's at least one way between every two villages.

Sample Input

1
3 3
0 1 5
0 2 0
1 2 9

Sample Output

5

#include <iostream>
#include <cstdio>
#include <cstring>
const int INF=1000000000;
const int maxn=510;
using namespace std;

int map[maxn][maxn],dis[maxn],visited[maxn];
int main()
{
	int n,a,b,k,i,j,N,E,mindistance,min,t;
	scanf("%d",&n);
	while (n--)
	{
		memset(visited,0,sizeof(visited));
		mindistance=0;
		scanf("%d%d",&N,&E);
		for (i=0;i<N;i++)
		{
			for (j=0;j<N;j++)
			{
				map[i][j]=INF;
			}
		}
		for (i=0;i<E;i++)
		{
			scanf("%d%d%d",&a,&b,&k);
			map[a][b]=map[b][a]=k;
		}
		for (j=0;j<N;j++)
		{
			dis[j]=map[0][j];
		}
		visited[0]=1;
		for (i=0;i<N;i++)
		{		
			min=INF;
			for (j=0;j<N;j++)
			{
				if(!visited[j] && min>dis[j])
				{
					min=dis[j];
					t=j;
				}
			}
			if(min!=INF)//值得注意的地方
				mindistance+=min;
			visited[t]=1;
			for (j=0;j<N;j++)
			{
				if (!visited[j] && dis[j]>map[t][j])
				{
					dis[j]=map[t][j];
				}
			}
		}
		printf("%d\n",mindistance);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值