【zoj1965】一天一个入门算法

**

Decode The Tree

**
A tree (i.e. a connected graph without cycles) with vertices numbered by the integers 1, 2, …, n is given. The “Prufer” code of such a tree is built as follows: the leaf (a vertex that is incident to only one edge) with the minimal number is taken. This leaf, together with its incident edge is removed from the graph, while the number of the vertex that was adjacent to the leaf is written down. In the obtained graph, this procedure is repeated, until there is only one vertex left (which, by the way, always has number n). The written down sequence of n-1 numbers is called the Prufer code of the tree.

Your task is, to reconstruct a tree, given its Prufer code. The tree should be denoted by a word of the language specified by the following grammar:
T ::= “(” N S “)”
S ::= " " T S
| empty
N ::= number

That is, trees have parentheses around them, and a number denoting the identifier of the root vertex, followed by arbitrarily many (maybe none) subtrees separated by a single space character. As an example, take a look at the tree in the figure below which is denoted in the first line of the sample output.

Note that, according to the definition given above, the root of a tree may be a leaf as well. It is only for the ease of denotation that we designate some vertex to be the root. Usually, what we are dealing here with is called an “unrooted tree”.

Input

The input contains several test cases. Each test case specifies the Prufer code of a tree on one line. You will find n-1 numbers separated by a single space. Input is terminated by EOF. You may assume that 1 <= n <= 50.

Output

For each test case generate a single line containing the corresponding tree, denoted as described above. Note that, in general, there are many ways to denote such a tree: choose your favourite one.

Sample Input

5 2 5 2 6 2 8
2 3
2 1 6 2 6

Sample Output

(8 (2 (3) (5 (1) (4)) (6 (7))))
(3 (2 (1)))
(6 (1 (4)) (2 (3) (5)))
第一行样例输入建立的树
这道题样例输入有点难看懂,其实逆向推理一下以后很快就可以看明白
说下思路就是这种树类型题目一般都是走递归的
另外prufer序列中有的除了最后一个都不是叶子结点,故我们可以很快得出叶子结点和非叶子结点,

注意:因为该题会出现n==1即输入数据(n-1)只有一个回车的情况,所以不能用scanf,getchar等。

可以用用sstream类库读取数据的方法(从大佬哪里得到的经验)

#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
#include<string>
#include<sstream>
#include<algorithm>
#include<vector>
using namespace std;
int f[55],ans[55];
vector<int> vec[55];
bool cmp(const int &a,const int &b)
{
	return a<b;
}
void dfs(int x)
{
	printf("(");
	printf("%d",x);
	int l=vec[x].size();
	sort(vec[x].begin(),vec[x].end(),cmp);//vector排序
	for(int i=0;i<l;i++)
	{
		printf(" ");
		dfs(vec[x][i]);
	}
	printf(")");
	vec[x].clear();//清空vector以防影响下组数据
}
int main()
{
	int i,n=0;
	char c;
	string line;
	memset(ans,0,sizeof(ans));
	while(getline(cin,line))//输入'EOF'停止
	{
		stringstream ss(line);//用sstream类库读取数据
		for(n=0;ss>>f[n];n++)//
			ans[f[n]]++;
		n--;
			priority_queue<int,vector<int>,greater<int> > leafs;
			for(i=1;i<=n+1;i++)
				if(!ans[i]) leafs.push(i);
			for(i=0;i<=n;i++)
			{
				int k=leafs.top();
				leafs.pop();
				vec[f[i]].push_back(k);
				if(--ans[f[i]]==0) leafs.push(f[i]);
			}
			if(n!=-1) dfs(f[n]);
			else printf("(1)");//输入为0
			printf("\n");
			memset(ans,0,sizeof(ans));
	}
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值