hdu 01背包问题 Bone Collector

Bone Collector

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 28   Accepted Submission(s) : 19
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

解题报告:

题目大意就是说,收集骨头,每一种骨头有起固定的体积及价值,最终就是在固定体积的背包里怎么样能够获得最大的价值,开始时候想到用贪心(按照价值来排序,依次相取),但是一直WA,后来用起了背包,发现简单多了。但是解题的关键还是在于背包的使用。。。

//#include<stdio.h>
//#include<algorithm>
//#include<string.h>
//using namespace std;
//struct inin
//{
//	int val;
//	int vol;
//}boy[10010];
//int cmp(inin a,inin b)
//{
//	return a.val>b.val;
//}
//int main()
//{
//	int T;
//	int sum;
//	int n,Vol;
//	int i,j;
//	scanf("%d",&T);
//	while(T--)
//	{
//		scanf("%d%d",&n,&Vol);
//		for(i=0;i<n;i++)
//		  scanf("%d",&boy[i].val);
//		for(j=0;j<n;j++)
//		  scanf("%d",&boy[j].vol);
//		sort(boy,boy+n,cmp);
//		sum=0;
//		for(i=0;i<n;i++)
//		{
//			if(Vol-boy[i].vol>=0)
//			{
//				sum+=boy[i].val;
//				Vol-=boy[i].vol;
//			}
//			else
//			{
//				break;
//			}
//		} 
//		printf("%d\n",sum);
//	} 
//return 0;
//} 
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct inin
{
	int val;
	int vol;
}boy[10010];
int main()
{
	int T;
	int sum;
	int n,Vol;
	int i,j;
	int bag[10010];
	scanf("%d",&T);
	while(T--)
	{
		memset(boy,0,sizeof(boy));
		memset(bag,0,sizeof(bag));
		scanf("%d%d",&n,&Vol);
		for(i=0;i<n;i++)
		  scanf("%d",&boy[i].val);
		for(j=0;j<n;j++)
		  scanf("%d",&boy[j].vol);
		for(i=0;i<n;i++)
		{
			for(j=Vol;j>=boy[i].vol;j--)
			{
				<strong><span style="color:#ff0000;">bag[j]=max(bag[j],bag[j-boy[i].vol]+boy[i].val);</span></strong>
			}
		}
		printf("%d\n",bag[Vol]);
	} 
return 0;
} 





Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值