POJ 1083 Moving Tables

Moving Tables
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22028 Accepted: 7261

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The  floor  has  200  rooms  each  on  the  north  side  and  south  side  along  the  corridor. Recently  the Company made a plan  to  reform  its  system. The  reform  includes moving a  lot of  tables between  rooms. Because  the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make  the moving efficient. The manager  figured out  the  following plan: Moving a  table  from a  room  to another  room can be done within 10 minutes. When moving a  table  from  room  i  to  room  j,  the part of  the corridor  between  the  front  of  room  i  and  the  front  of  room  j  is  used.  So,  during  each  10 minutes,  several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables.  Your job is to write a program to solve the manager's problem.

Input

The input consists of T  test cases. The number of test cases  ) (T  is given in the first line of the input file. Each test case begins with a line containing an integer  N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following  N  lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the  3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source

解题思路:开始这一题我想错了,认为每次输入后将新区间与之前的区间进行对比来算出区间的重复值,但是这样可能导致一些并行区间被与某区间重叠部分重复计算,要消去这些重叠部分有难以做到,所以这个思路是错误的。实际上,只要计算房间前的走廊被重复使用多少次,再找出使用最多的那段走廊,将其使用次数乘以10就是最终答案。注意一些前期工作要做好,比如始终将移动区间的左值设为奇数,右值设为偶数,因为[4,7]区间是等价于[3,8]区间的,然后让左值始终小于右值,这样做是为了之后统计房间前走廊使用次数方便。其实这一题画个图就什么都看出来了,我还WA了几次,= =!
#include<iostream>
using namespace std;
struct 
{
	int left,right;
}Move[210];
int room[401];
int main()
{
	int i,j,num,test,time;
	cin>>test;
	while(test--)
	{
		time=-1;
		memset(room,0,sizeof(room));
		for(i=0;i<210;i++)
			Move[i].left=Move[i].right=0;
		cin>>num;
		for(i=1;i<=num;i++)
		{
			cin>>Move[i].left>>Move[i].right;
			if(Move[i].left>Move[i].right)
				swap(Move[i].left,Move[i].right);
			if(Move[i].right%2)
				if(Move[i].left%2)
				Move[i].right+=1;
				else
				{Move[i].right+=1;Move[i].left-=1;}
			else if((Move[i].left%2)==0)
				Move[i].left-=1;
			for(j=Move[i].left;j<=Move[i].right;j++)
					room[j]++;
		}
		for(i=1;i<=400;i++)
			if(time<room[i])
				time=room[i];
        cout<<time*10<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值