POJ 1083 Moving Tables

Moving Tables
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22028 Accepted: 7261

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The  floor  has  200  rooms  each  on  the  north  side  and  south  side  along  the  corridor. Recently  the Company made a plan  to  reform  its  system. The  reform  includes moving a  lot of  tables between  rooms. Because  the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make  the moving efficient. The manager  figured out  the  following plan: Moving a  table  from a  room  to another  room can be done within 10 minutes. When moving a  table  from  room  i  to  room  j,  the part of  the corridor  between  the  front  of  room  i  and  the  front  of  room  j  is  used.  So,  during  each  10 minutes,  several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables.  Your job is to write a program to solve the manager's problem.

Input

The input consists of T  test cases. The number of test cases  ) (T  is given in the first line of the input file. Each test case begins with a line containing an integer  N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following  N  lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the  3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source

解题思路:开始这一题我想错了,认为每次输入后将新区间与之前的区间进行对比来算出区间的重复值,但是这样可能导致一些并行区间被与某区间重叠部分重复计算,要消去这些重叠部分有难以做到,所以这个思路是错误的。实际上,只要计算房间前的走廊被重复使用多少次,再找出使用最多的那段走廊,将其使用次数乘以10就是最终答案。注意一些前期工作要做好,比如始终将移动区间的左值设为奇数,右值设为偶数,因为[4,7]区间是等价于[3,8]区间的,然后让左值始终小于右值,这样做是为了之后统计房间前走廊使用次数方便。其实这一题画个图就什么都看出来了,我还WA了几次,= =!
#include<iostream>
using namespace std;
struct 
{
	int left,right;
}Move[210];
int room[401];
int main()
{
	int i,j,num,test,time;
	cin>>test;
	while(test--)
	{
		time=-1;
		memset(room,0,sizeof(room));
		for(i=0;i<210;i++)
			Move[i].left=Move[i].right=0;
		cin>>num;
		for(i=1;i<=num;i++)
		{
			cin>>Move[i].left>>Move[i].right;
			if(Move[i].left>Move[i].right)
				swap(Move[i].left,Move[i].right);
			if(Move[i].right%2)
				if(Move[i].left%2)
				Move[i].right+=1;
				else
				{Move[i].right+=1;Move[i].left-=1;}
			else if((Move[i].left%2)==0)
				Move[i].left-=1;
			for(j=Move[i].left;j<=Move[i].right;j++)
					room[j]++;
		}
		for(i=1;i<=400;i++)
			if(time<room[i])
				time=room[i];
        cout<<time*10<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于C++&OPENCV 的全景图像拼接 C++是一种广泛使用的编程语言,它是由Bjarne Stroustrup于1979年在新泽西州美利山贝尔实验室开始设计开发的。C++是C语言的扩展,旨在提供更强大的编程能力,包括面向对象编程和泛型编程的支持。C++支持数据封装、继承和多态等面向对象编程的特性和泛型编程的模板,以及丰富的标准库,提供了大量的数据结构和算法,极大地提高了开发效率。12 C++是一种静态类型的、编译式的、通用的、大小写敏感的编程语言,它综合了高级语言和低级语言的特点。C++的语法与C语言非常相似,但增加了许多面向对象编程的特性,如类、对象、封装、继承和多态等。这使得C++既保持了C语言的低级特性,如直接访问硬件的能力,又提供了高级语言的特性,如数据封装和代码重用。13 C++的应用领域非常广泛,包括但不限于教育、系统开发、游戏开发、嵌入式系统、工业和商业应用、科研和高性能计算等领域。在教育领域,C++因其结构化和面向对象的特性,常被选为计算机科学和工程专业的入门编程语言。在系统开发领域,C++因其高效性和灵活性,经常被作为开发语言。游戏开发领域中,C++由于其高效性和广泛应用,在开发高性能游戏和游戏引擎中扮演着重要角色。在嵌入式系统领域,C++的高效和灵活性使其成为理想选择。此外,C++还广泛应用于桌面应用、Web浏览器、操作系统、编译器、媒体应用程序、数据库引擎、医疗工程和机器人等领域。16 学习C++的关键是理解其核心概念和编程风格,而不是过于深入技术细节。C++支持多种编程风格,每种风格都能有效地保证运行时间效率和空间效率。因此,无论是初学者还是经验丰富的程序员,都可以通过C++来设计和实现新系统或维护旧系统。3

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值