杭电 ACM 1008 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71382    Accepted Submission(s): 39215


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41
 

Author
ZHENG, Jianqiang
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1002  1009  1021  1108  1019 


#include<iostream>
#include<string>
using namespace std;
int main(void)
{
	int evl;
	int pre = 0;
	int up, down, stay;
	up = 6; down = 4; stay = 5;
	int sum = 0;
	int n;
	char c;
	while (1)
	{
		cin >> n;
		if (0 == n) break;
		else
		{
			for (int i = 0; i < n; i++)
			{
				cin >> evl;
				if (evl > pre)
				{
					sum += ((evl - pre)*up);
				}
				else
				{
					sum += ((pre - evl)*down);
				}
				pre = evl;
				sum += 5;//停一次就加5,
			}
		}
		cout << sum << endl;
		sum = 0;
		pre = 0;
	}
}

巨坑,没看到每一行前面的那个N是接下来要输入的楼层的个数,搞的算了半天都不对
在思考中也犯了一个错误,把等待时间理解成了,每次经过一个楼层都要等待,但实际情况是只有到达目标楼层才会停一次
(每层都停说不定坐电梯还没爬楼梯快 O__O "…) 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值