杭电ACM 1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 170412    Accepted Submission(s): 42042


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1021  1019  1002  1001 


#include<iostream>
using namespace std;
typedef long long ll;
const int mod=7;
#define N 2
struct matrix
{
	ll a[2][2];
};
matrix multiple(matrix x, matrix y, int n)
{
	matrix tmp;
	memset(tmp.a, 0, sizeof(tmp.a));
	for (int i = 0; i < n; i++)
		for (int j = 0; j < n; j++)
			for (int k = 0; k < n; k++)
				tmp.a[i][j] = (tmp.a[i][j] + (x.a[i][k] * y.a[k][j]) % mod) % mod;
	return tmp;
}
int main(void)
{
	matrix res;
	int a, b, n;
	cin >> a >> b >> n;
	while (a != 0 && b != 0 && n != 0)
	{
		memset(res.a, 0, sizeof(res.a));
		for (int i = 0; i<2; i++) {
			res.a[i][i] = 1;
		}
		if (n == 1 || n == 2)
			cout << 1 << endl;
		else
		{
			n -= N;
			matrix tmp = { a,b,
				           1,0 };
			while (n)
			{
				if (n & 1) res= multiple(res, tmp, N);
				n >>= 1;
				tmp=multiple(tmp, tmp, N);
				
			}
			cout << (res.a[0][0] + res.a[0][1]) % mod << endl;
		}
		cin >> a >> b >> n;
	}
}


知识来源:
http://www.cnblogs.com/CXCXCXC/p/4641812.html  
http://blog.csdn.net/wust_zzwh/article/details/52058209
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值