HDU 1316 How Many Fibs? (大Fib数,还是Java大法好)

153 篇文章 0 订阅
12 篇文章 0 订阅

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5822    Accepted Submission(s): 2267


Problem Description
Recall the definition of the Fibonacci numbers: 
f1 := 1 
f2 := 2 
fn := fn-1 + fn-2 (n >= 3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
 

Source


题意:求指定区间里有多少个Fib数.
果断打表,将所有的Fib数按顺寻存在数组中,但是数组长度是多大呢?题目中只说了Fib数的的区间上限是10^100,期间有多少个Fib数并不知道,所以首先得确定数组大小!

AC代码:

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		
		Scanner sc = new Scanner(System.in);
		final int MAXN = 1000+5;
		BigDecimal [] a = new BigDecimal[MAXN];
		a[1]=new BigDecimal(1);
		a[2]=new BigDecimal(2);
		for (int i = 3; i <MAXN; i++) {
			a[i] = a[i-1].add(a[i-2]);
		}
		//System.out.println(a[MAXN-1]);
		//System.out.println(a[MAXN-1].toString().length());
		while(sc.hasNext()){
			BigDecimal start = sc.nextBigDecimal();
			BigDecimal end = sc.nextBigDecimal();
			BigDecimal zero = BigDecimal.ZERO;
			if(start.compareTo(zero)==0&&end.compareTo(zero)==0){
				break;
			}
			int sum = 0;
			for (int i = 1; i < MAXN; i++) {
				if(a[i].compareTo(start)<0){
					continue;
				}else if(a[i].compareTo(end)>0){
					break;
				}else{
					sum++;
				}
			}
			System.out.println(sum);
		}

	}

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值