Ubuntu+Nginx+PHP的最简搭建方法

前言:百度出来的结果好坑爹,而且某些文章说别人坑爹,可他自己也坑爹。求业界良心啊。还是谷歌靠谱。 系统环境:Ubuntu 13 和 Linux Mint 15都通过。 先安装: sudo apt-get install nginx php5-fpm 我是在新安装的Ubuntu13上测试通过的,真的只安装这两个东西就够了。 然后编辑配置文件。 sudo gedit...
阅读(23752) 评论(2)

Linux Mint + Nginx 1.5.11搭建SSL/HTTPS/SPDY服务器

Apache搭建的SPDY服务器(Linux Mint + Apache2.2搭建SSL/HTTPS/SPDY服务器)很不爽,因为Apache只能用2.2版本,SPDY也只支持到3,不支持3.1。所以用Nginx好些。 用以下脚本安装: wget http://nginx.org/download/nginx-1.5.11.tar.gz tar jxvf nginx-1.5.11.tar.gz...
阅读(3783) 评论(4)

使用支持SPDY协议的Wireshark截包(含spdyshark插件)

本文基于前三篇文章,请先阅读: Linux Mint + Apache2.2搭建SSL/HTTPS/SPDY服务器Wireshark+Apache2.4解密SSLv3Linux Mint下编译安装支持SPDY协议的Wireshark...
阅读(6332) 评论(1)

Linux Mint下编译安装支持SPDY协议的Wireshark

做成脚本了,保存成文件,sudo ./xxx.sh即可。 #!/bin/bash # 如果没有加sudo,提示错误并退出 if [ "x$(id -u)" != x0 ]; then echo "Error: please run this script with 'sudo'." exit 1 fi #下载和解压wireshark源码 wget http...
阅读(3180) 评论(0)

Wireshark+Apache2.4解密SSLv3

首先说明一下,网上很多资料没提到下面两点: Wireshark只能解密SSL,不能解密TSLWireshark不能解密应用了DH(Diffie–Hellman)密码的SSL密文 因为这两个原因,就需要好好配置apache了。还有两点要注意: Apache2.2有bug没能禁用TSL,所以只能在Apache2.4上做提供给Wireshark的key文件,必须是 内含pkcs...
阅读(7757) 评论(4)
    个人资料
    • 访问:1043958次
    • 积分:9592
    • 等级:
    • 排名:第2064名
    • 原创:173篇
    • 转载:0篇
    • 译文:0篇
    • 评论:539条
    联系方式
    微信:hursing

    前阿里巴巴技术专家。现参与互联网金融创业,广招程序员~
    博客专栏
    最新评论