Maze Exploration
A maze of rectangular rooms is represented on a two dimensional grid as illustrated in figure 1a. Each point of the grid is represented by a character. The points of room walls are marked by the same character which can be any printable character different than `*', `_' and space. In figure 1 this character is `X'. All the other points of the grid are marked by spaces.
a) Initial maze b) Painted maze
Figure 1. Mazes of rectangular rooms
All rooms of the maze are equal sized with all walls 3 points wide and 1 point thick as illustrated in figure 2. In addition, a wall is shared on its full length by the separated rooms. The rooms can communicate through doors, which are positioned in the middle of walls. There are no outdoor doors.
Figure 2. A room with 3 doors
Your problem is to paint all rooms of a maze which can be visited starting from a given room, called the `start room' which is marked by a star (`*') positioned in the middle of the room. A room can be visited from another room if there is a door on the wall which separates the rooms. By convention, a room is painted if its entire surface, including the doors, is marked by the character `#' as shown in figure 1b.
Input
The program input is a text file structured as follows:
1.
The first line contains a positive integer which shows the number of mazes to be painted.
2.
The rest of the file contains the mazes.
The lines of the input file can be of different length. The text which represents a maze is terminated by a separation line full of underscores (`_'). There are at most 30 lines and at most 80 characters in a line for each maze
The program reads the mazes from the input file, paints them and writes the painted mazes on the standard output.
Output
The output text of a painted maze has the same format as that which has been read for that maze, including the separation lines. The example below illustrates a simple input which contains a single maze and the corresponding output.
Sample Input
2
Sample Output
A maze of rectangular rooms is represented on a two dimensional grid as illustrated in figure 1a. Each point of the grid is represented by a character. The points of room walls are marked by the same character which can be any printable character different than `*', `_' and space. In figure 1 this character is `X'. All the other points of the grid are marked by spaces.
XXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXX
X X X X X X X###X###X###X X X
X X X X X###########X X X
X X X X X X X###X###X###X X X
XXXXXX XXX XXXXXXXXXX XXXXXX#XXX#XXXXXXXXXX
X X X X X X X X###X###X###X###X
X X * X X X###############X
X X X X X X X X###X###X###X###X
XXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXX
a) Initial maze b) Painted maze
Figure 1. Mazes of rectangular rooms
All rooms of the maze are equal sized with all walls 3 points wide and 1 point thick as illustrated in figure 2. In addition, a wall is shared on its full length by the separated rooms. The rooms can communicate through doors, which are positioned in the middle of walls. There are no outdoor doors.
door
|
XX XX
X . X measured from within the room
door - ...-- walls are 3 points wide
X . X__
XXXXX |
|___ walls are one point thick
Figure 2. A room with 3 doors
Your problem is to paint all rooms of a maze which can be visited starting from a given room, called the `start room' which is marked by a star (`*') positioned in the middle of the room. A room can be visited from another room if there is a door on the wall which separates the rooms. By convention, a room is painted if its entire surface, including the doors, is marked by the character `#' as shown in figure 1b.
Input
The program input is a text file structured as follows:
1.
The first line contains a positive integer which shows the number of mazes to be painted.
2.
The rest of the file contains the mazes.
The lines of the input file can be of different length. The text which represents a maze is terminated by a separation line full of underscores (`_'). There are at most 30 lines and at most 80 characters in a line for each maze
The program reads the mazes from the input file, paints them and writes the painted mazes on the standard output.
Output
The output text of a painted maze has the same format as that which has been read for that maze, including the separation lines. The example below illustrates a simple input which contains a single maze and the corresponding output.
Sample Input
2
XXXXXXXXX
X X X
X * X
X X X
XXXXXXXXX
X X
X X
X X
XXXXX
_____
XXXXX
X X
X * X
X X
XXXXX
_____
Sample Output
XXXXXXXXX
X###X###X
X#######X
X###X###X
XXXXXXXXX
X X
X X
X X
XXXXX
_____
XXXXX
X###X
X###X
X###X
XXXXX
_____
题意:很水啊,其实光看输入输出就可以理解题意了。。把'*'能"通过"的地方都变成'#',' '都是可以通过的,没有''X"的地方都可以通过。。用DFS就可以了。。
#include <iostream>
#include <string>
#include <cstdio>
using namespace std;
string vie[31];
string str;
int flag[3]={-1,0,1},k;
void dfs(int x,int y)
{
vie[x][y]='#';
int x0,y0;
for(int i=0;i<3;i++)
for(int j=0;j<3;j++)
{
x0=x+flag[i];
y0=y+flag[j];
if(vie[x0][y0]==' ')
dfs(x0,y0);
}
}
int main ()
{
int n,i,j;
cin >> n;
getchar();
while(n--)
{
k=0;
while(getline(cin,str))
{
vie[k++]=str;
if(str[0]=='_')
break;
}
for(i=0;i<k-1;i++)
for(j=0;j<vie[i].size();j++)
if(vie[i][j]=='*')
dfs(i,j);
for(i=0;i<k;i++)
cout << vie[i] <<endl;
}
return 0;
}