[DP]HDOJ1158 Employment Planning

17 篇文章 0 订阅
7 篇文章 0 订阅

[题目]

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4246    Accepted Submission(s): 1776


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
  
  
3 4 5 6 10 9 11 0
 

Sample Output
  
  
199
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1227  1074  1080  1024  1078 
 

Statistic |  Submit |  Discuss | Note

[思路]

1.很显然的一道DP,f[i][j]表示i月取j人,m[i]保存该月最少需要人数,mm表示可能出现的最大人数,work()计算从k转移到j人的花费。

初始化:

f[0][i]=聘金×i;i=0...mm.

方程:

f[i][j]=min{f[i-1][k]+work(k,j)};i=1...n|j=m[i]...mm|k=m[i-1]...mm.

复杂度O(mm^2*n)。

2.还有一种O(n^2)方法。

[代码]

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
#define INF 1e9
#define LOCAL

int n,hh,ss,ff,f[13][105],mm,m[13],ans;

int work(int a,int b)
{
	if(a==b)
		return b*ss;
	else if(a>b)
		return b*ss+(a-b)*ff;
	else return b*ss+(b-a)*hh;
}

int main()
{
#ifdef LOCAL
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
#endif
	ios::sync_with_stdio(false);
	while(cin>>n,n)
	{
		cin>>hh>>ss>>ff;
		mm=0;m[0]=0;
		for(int i=1;i<=n;++i)
		{
			cin>>m[i];
			mm=max(mm,m[i]);
		}
		f[0][0]=0;
		for(int i=1;i<=mm;++i)
            f[0][i]=f[0][i-1]+hh;
		for(int i=1;i<=n;++i)
			for(int j=m[i];j<=mm;++j)
			{
				f[i][j]=INF;
				for(int k=m[i-1];k<=mm;++k)
					f[i][j]=min(f[i][j],f[i-1][k]+work(k,j));
			}
		ans=INF;
		for(int i=m[n];i<=mm;++i)
			ans=min(f[n][i],ans);
		cout<<ans<<endl;
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值