HDOJ 题目1158Employment Planning(DP)

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4288    Accepted Submission(s): 1795


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
  
  
3 4 5 6 10 9 11 0
 

Sample Output
  
  
199
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1227  1074  1080  1300  3008 
 

题目大意:

先给出一个n表示那个月,下边一行三个数,分别表示录取一个人需要的消耗,每个人每个月的工资,炒掉一个人需要的消耗,在接下来一行n个数,表示每个月最少需要的人数,问最少的消耗

ac代码


#include<stdio.h>
#include<string.h>
#define min(a,b) (a>b?b:a)
#define LL __int64
#define INF 0x3f3f3f3f
LL dp[13][10010];
LL a[13];
int main()
{
	LL n;
	while(scanf("%I64d",&n)!=EOF,n)
	{
		LL i,j,k;
		LL maxn=0;
		LL h,s,f;
		scanf("%I64d%I64d%I64d",&h,&s,&f);
		for(i=1;i<=n;i++)
		{
			scanf("%I64d",&a[i]);
			if(maxn<a[i])
				maxn=a[i];
		}
		memset(dp,INF,sizeof(dp));
		for(j=a[1];j<=maxn;j++)
		{
			dp[1][j]=j*s+j*h;
	//		printf("%lld\n",dp[1][j]);
		}
		for(i=2;i<=n;i++)
		{
			for(j=a[i];j<=maxn;j++)
			{
				LL minn=INF;
				for(k=a[i-1];k<=maxn;k++)
				{
					LL temp;
					if(j>=k)
						temp=dp[i-1][k]+(j*s+(j-k)*h);
					else
						temp=dp[i-1][k]+(j*s+(k-j)*f);
					minn=min(minn,temp);
				}
				dp[i][j]=minn;
			}
		}
		LL ans=INF;
		for(i=a[n];i<=maxn;i++)
		{
			if(dp[n][i]<ans)
				ans=dp[n][i];
		}
		printf("%I64d\n",ans);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值